POV-Ray : Newsgroups : povray.programming : Problems with editor dll Server Time
12 Jun 2024 17:51:33 EDT (-0400)
  Problems with editor dll (Message 1 to 5 of 5)  
From: mosaik
Subject: Problems with editor dll
Date: 26 Dec 2009 17:30:01
Message: <web.4b368e131d54116435bf58e0@news.povray.org>
Hi,

I have some problems getting povray 3.6 compiled and running:
* I use Visual C++ 2008 Express edition
* when starting pvengine.exe (after having compiled it) I get the following
error message: ERROR: wrong editor DLL version [expected 0301, got 0300]

So it seems that the current source download for windows is inconsistent!? How
can I resolve this problem? Can someone provide the matching editor DLL version?

thank you,

Andi


Post a reply to this message

From: Nicolas Alvarez
Subject: Re: Problems with editor dll
Date: 26 Dec 2009 21:57:32
Message: <4b36cd1c@news.povray.org>
mosaik wrote:
> I have some problems getting povray 3.6 compiled and running:
> * I use Visual C++ 2008 Express edition
> * when starting pvengine.exe (after having compiled it) I get the
> following error message: ERROR: wrong editor DLL version [expected 0301,
> got 0300]
> 
> So it seems that the current source download for windows is inconsistent!?
> How can I resolve this problem? Can someone provide the matching editor
> DLL version?

Did you compile the editor from source too, or did you take the editor DLL 
from a binary POV-Ray installation? If the latter, what version of POV-Ray 
was it?


Post a reply to this message

From: mosaik
Subject: Re: Problems with editor dll
Date: 28 Dec 2009 10:30:00
Message: <web.4b38cebf9362de08b088b72d0@news.povray.org>
Nicolas Alvarez <nic### [at] gmailcom> wrote:
> mosaik wrote:
> > I have some problems getting povray 3.6 compiled and running:
> > * I use Visual C++ 2008 Express edition
> > * when starting pvengine.exe (after having compiled it) I get the
> > following error message: ERROR: wrong editor DLL version [expected 0301,
> > got 0300]
> >
> > So it seems that the current source download for windows is inconsistent!?
> > How can I resolve this problem? Can someone provide the matching editor
> > DLL version?
>
> Did you compile the editor from source too, or did you take the editor DLL
> from a binary POV-Ray installation? If the latter, what version of POV-Ray
> was it?

I have POV-Ray 3.6.1c.icl8.win32 installed.
And I downloaded the windows source just a few days ago. I did not compile the
editor (as suggested in the README). When starting vs2008\bin32\pvengine.exe I
get the above error message. The version is 3.6.2.msvc9.unofficial-win32. I do
not know, where pvengine loads the DLLs from, since there are no DLLs in the
povwin-3.62 directory!?

Andi


Post a reply to this message

From: Nicolas Alvarez
Subject: Re: Problems with editor dll
Date: 28 Dec 2009 14:15:12
Message: <4b3903c0$1@news.povray.org>
mosaik wrote:
> I have POV-Ray 3.6.1c.icl8.win32 installed.
> And I downloaded the windows source just a few days ago. I did not compile
> the editor (as suggested in the README). When starting
> vs2008\bin32\pvengine.exe I get the above error message. The version is
> 3.6.2.msvc9.unofficial-win32. I do not know, where pvengine loads the DLLs
> from, since there are no DLLs in the povwin-3.62 directory!?

POV-Ray 3.6.2 has a newer and incompatible editor DLL. If you're compiling 
povrin-3.62, you need the editor DLL from a 3.6.2 release (or compile it 
yourself).

Get 3.6.2 from the usual place: http://povray.org/download/#binaries


Post a reply to this message

From: mosaik
Subject: Re: Problems with editor dll
Date: 29 Dec 2009 05:35:01
Message: <web.4b39da799362de088ac27d330@news.povray.org>
Nicolas Alvarez <nic### [at] gmailcom> wrote:
> mosaik wrote:
> > I have POV-Ray 3.6.1c.icl8.win32 installed.
> > And I downloaded the windows source just a few days ago. I did not compile
> > the editor (as suggested in the README). When starting
> > vs2008\bin32\pvengine.exe I get the above error message. The version is
> > 3.6.2.msvc9.unofficial-win32. I do not know, where pvengine loads the DLLs
> > from, since there are no DLLs in the povwin-3.62 directory!?
>
> POV-Ray 3.6.2 has a newer and incompatible editor DLL. If you're compiling
> povrin-3.62, you need the editor DLL from a 3.6.2 release (or compile it
> yourself).
>
> Get 3.6.2 from the usual place: http://povray.org/download/#binaries

Ok, now I understand: the source distribution is not (fully) self-contained; if
not compiled by one self the editor DLL is taken from a binary release. (Now I
found the corresponding NOTE in the README. I think it should be moved from the
"FULL DETAILS" section to "SO YOU WANT .. QUICK START ..".)

thank you for your help!

Andi


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.