POV-Ray : Newsgroups : povray.general : First unofficial patch of POV-Ray 3.7.0: UberPOV : Re: First unofficial patch of POV-Ray 3.7.0: UberPOV Server Time
17 Sep 2021 22:23:05 EDT (-0400)
  Re: First unofficial patch of POV-Ray 3.7.0: UberPOV  
From: Ive
Date: 18 Nov 2013 11:32:02
Message: <528a4102$1@news.povray.org>
Using VS2010 I get 3 compile time errors

1>..\..\source\backend\lighting\photons.cpp(417): error C2661: 
'pov::Trace::WNRX::WNRX' : no overloaded function takes 4 arguments

3>..\..\vfe\vfedisplay.cpp(61): error C2661: 
'pov_frontend::Display::Display' : no overloaded function takes 4 arguments

3>C:\Work\POV\UberPov\libraries\boost\boost/bind/bind.hpp(515): error 
C2593: 'operator [' is ambiguous

and as a result a link error as povbackend64.lib is not build.

Official POV 3.7 works.


As a side note: I'm curious to see how adaptive multi-level oversampling 
works out. To be honest, I'm considering to switch to a commercial 
render engine (I did already use the trial versions of the Maxwell and 
VRay renderer), not because of better quality but because both are so 
much faster when working with more complex scenes where e.g. things 
happen like blurred inter-reflections.
IMO the way POV-Ray implements various independent multi-sampling 
methods for various features (media, area_lights, focal blur and so 
on..) is the culprit here.

-Ive


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.