POV-Ray : Newsgroups : povray.advanced-users : Object Oriented POV code : Re: Object Oriented POV code Server Time
29 Jul 2024 14:25:22 EDT (-0400)
  Re: Object Oriented POV code  
From: Christopher James Huff
Date: 21 Feb 2004 15:07:46
Message: <cjameshuff-AA4FEE.15082721022004@news.povray.org>
In article <40363a68@news.povray.org>, Warp <war### [at] tagpovrayorg> 
wrote:

>   Color myColor(.1, .2, .3);
> 
>   (Instead of "Color myColor = Color(.1, .2, .3);")
> 
>   No need for 'new', and there's no ambiguity.

I think you meant "redundancy"...this is something that really annoys me 
about Java, and about C++ pointers. Though the syntax I favor is more 
like:

def myColor: Color(0.1, 0.2, 0.3);

No more redundant typing, but it always starts with the same keyword, so 
it's a little easier to read.


> > >   There's a reason why in Java everything is not an instance of a class.
> 
> > I think everything should have been.
> 
>   Really? Then good luck trying to write things like "a = b+c;" in Java...

That's not a problem with C++ objects, why should it be a problem with 
Java objects? Or are you assuming that this "Objective-Java" would still 
lack operator overloading?

-- 
Christopher James Huff <cja### [at] earthlinknet>
http://home.earthlink.net/~cjameshuff/
POV-Ray TAG: <chr### [at] tagpovrayorg>
http://tag.povray.org/


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.