POV-Ray : Newsgroups : povray.binaries.images : Poseray issue or me Server Time: 27 Sep 2020 18:55:02 GMT
  Poseray issue or me (Message 1 to 10 of 12)  
Goto Latest 10 Messages Next 2 Messages >>>
From: Melody
Subject: Poseray issue or me
Date: 10 Sep 2020 17:05:00
Message: <web.5f5a5b81b151c10564b5a7ab0@news.povray.org>
Was just trying to rebuild a model with PoseRay,

mesh {
smooth_triangle {
<-5.079832,1.040415,-0.471838>,
<1.000000,0.000000,0.000000>,
<-5.079832,1.347545,2.03252>,
<1.000000,0.000000,0.000000>,
<-5.079832,1.405724,-0.471899>,
<1.000000,0.000000,0.000000>
}
smooth_triangle {
<-5.079832,1.347545,2.03252>,
<1.000000,0.000000,0.000000>,
<-5.079832,1.040415,-0.471838>,
<1.000000,0.000000,0.000000>,
<-5.079832,1.048656,2.03252>,
<1.000000,0.000000,0.000000>
}
texture { warp_r }
}


1 mesh ok; add another side, texture1 now has 3 triangles.
Texture2 only one.
ADD a third mesh, texture1 is everything except one triangle in other objects ??

PoseRay bug, or is it me?
any ideas?
poseray_3_13_29


Post a reply to this message


Attachments:
Download 'poseray.jpg' (44 KB)

Preview of image 'poseray.jpg'
poseray.jpg


 

From: Melody
Subject: Re: Poseray issue or me
Date: 10 Sep 2020 17:25:01
Message: <web.5f5a604efe69494b64b5a7ab0@news.povray.org>
If it is a bug, I cannot find older versions of PoseRay,
nor a home site other than Google.

Older versions ??


Post a reply to this message

From: Melody
Subject: Re: Poseray issue or me
Date: 10 Sep 2020 17:35:00
Message: <web.5f5a62b2fe69494b64b5a7ab0@news.povray.org>
"Melody" <nomail@nomail> wrote:
> If it is a bug, I cannot find older versions of PoseRay,
> nor a home site other than Google.
>
> Older versions ??

https://sites.google.com/site/poseray/home-1

older versions link - trying something else.
should have done that first. ought to tell if latest needs or fix or *I need a
fix. doh.


Post a reply to this message

From: Melody
Subject: Re: Poseray issue or me
Date: 10 Sep 2020 18:35:01
Message: <web.5f5a719afe69494b64b5a7ab0@news.povray.org>
poseray_3_12_0

1st version to highlight mesh in red by material.
same thing - texture1 hogs all triangles but 1 in all other meshes.

well, I guess that's out of range of possibility


Post a reply to this message

From: Bald Eagle
Subject: Re: Poseray issue or me
Date: 10 Sep 2020 20:10:01
Message: <web.5f5a86f9fe69494b1f9dae300@news.povray.org>
"Melody" <nomail@nomail> wrote:

> 1 mesh ok; add another side, texture1 now has 3 triangles.

OK, I think I'm following.

> Texture2 only one.

You only assign Teture2 to one triangle?

> ADD a third mesh, texture1 is everything except one triangle in other objects ??

This is where I completely lose what's going on...


Post a reply to this message

From: Melody
Subject: Re: Poseray issue or me
Date: 11 Sep 2020 21:45:07
Message: <web.5f5beefbfe69494b64b5a7ab0@news.povray.org>
"Bald Eagle" <cre### [at] netscapenet> wrote:
> "Melody" <nomail@nomail> wrote:
> > 1 mesh ok; add another side, texture1 now has 3 triangles.
> OK, I think I'm following.
> > Texture2 only one.
> You only assign Teture2 to one triangle?
> > ADD a third mesh, texture1 is everything except one triangle in other objects ??
> This is where I completely lose what's going on...

Yeah me too. So I exported each mesh separately * 14, to POV-Scene, now we got
mesh2, rebuilt the inc file. But in the end, it's all material_0 --- materials
tab - tools -- groups -> materials !!yea POSERAY!

Now I got a list of materials to make.
Needed to edit a json material. - smoothing yet to do for Warbird, more to fix.

OpenGL
http://innerbeing.epizy.com/cwebgl/WebGLEarth.html
http://innerbeing.epizy.com/code/codewgl.html


Post a reply to this message


Attachments:
Download 'screen.jpg' (52 KB)

Preview of image 'screen.jpg'
screen.jpg


 

From: Melody
Subject: Re: Poseray issue or me
Date: 11 Sep 2020 21:50:07
Message: <web.5f5bf0bbfe69494b64b5a7ab0@news.povray.org>
Serendipity again


Post a reply to this message


Attachments:
Download 'warbird_pov_geom_pov_scene.png' (180 KB)

Preview of image 'warbird_pov_geom_pov_scene.png'
warbird_pov_geom_pov_scene.png


 

From: Thomas de Groot
Subject: Re: Poseray issue or me
Date: 12 Sep 2020 06:23:41
Message: <5f5c696d$1@news.povray.org>
Op 11/09/2020 om 23:49 schreef Melody:
> Serendipity again
> 

Now, unless I am mistaken, this typically looks like a case of 
non-merged vertices. Some programs export that way and Poseray does not 
fail to show it when using 'Subdivision'. In those cases my solution has 
always been: in Poseray, before using 'Subdivision', do a 'Weld 
Vertices' in the 'Groups' menu and all will be well.

But maybe you did this on purpose...? ;-)

-- 
Thomas


Post a reply to this message

From: Melody
Subject: Re: Poseray issue or me
Date: 12 Sep 2020 11:15:00
Message: <web.5f5cacbffe69494b64b5a7ab0@news.povray.org>
Thomas de Groot <tho### [at] degrootorg> wrote:
> Op 11/09/2020 om 23:49 schreef Melody:
> > Serendipity again
> >
>
> Now, unless I am mistaken, this typically looks like a case of
> non-merged vertices. Some programs export that way and Poseray does not
> fail to show it when using 'Subdivision'. In those cases my solution has
> always been: in Poseray, before using 'Subdivision', do a 'Weld
> Vertices' in the 'Groups' menu and all will be well.
>
> But maybe you did this on purpose...? ;-)
>
> --
> Thomas

Yes, 10 secs to throw into renderer, looked coolish.
So many buttons so little brain power to deal with it.

I never figured out importing more than one mesh.
but once I got them all into a mesh2, just one file.

More than one mesh, it would "miss" triangles, and meld meshes into one texture.
Other textures were the missing triangles -as seen in the first image with
texture selection.

I have more blender models of the fleet than what can be found on Google it
seems. Solar System now runs in browser 50 fps. woo hoo!


Post a reply to this message


Attachments:
Download 'warbird2b_pov_scene.png' (45 KB)

Preview of image 'warbird2b_pov_scene.png'
warbird2b_pov_scene.png


 

From: Melody
Subject: Re: Poseray issue or me
Date: 12 Sep 2020 11:55:00
Message: <web.5f5cb5a9fe69494b64b5a7ab0@news.povray.org>
Anyway, I see Recalculate normals- hit smooth and crease angle goes to 180.

Smoothed just fine in POV, but poseRay is not rendering the smooth model.
The converted json is apparently not getting vertex normals.

Did PoseRay recalculate face norms or vertex norms for smoothing? Because
PoseRay still renders flat after recalculating.
need to study formats and see things for myself.


Post a reply to this message


Attachments:
Download 'vertexnormbuttonq.jpg' (35 KB)

Preview of image 'vertexnormbuttonq.jpg'
vertexnormbuttonq.jpg


 

Goto Latest 10 Messages Next 2 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.