POV-Ray : Newsgroups : povray.unix : no EXR in linux : Re: no EXR in linux Server Time
7 Dec 2021 16:30:21 EST (-0500)
  Re: no EXR in linux  
From: green
Date: 25 Apr 2018 12:05:01
Message: <web.5ae0a6e03b43820f9f3726380@news.povray.org>
Le_Forgeron <lef### [at] freefr> wrote:
> Le 25/04/2018 à 03:24, green a écrit :
> > linux versions 3.7, 3.8 and uberpov will not write or read EXR file formats.
> > trying to write gives a command-line-option error, whereas trying to read an EXR
> > gives a more useful
> >
> > This unofficial POV-Ray  binary was built without support for the OpenEXR file
> > format.  You must either  use an official POV-Ray binary or recompile the
> > POV-Ray sources on a system  providing you with the OpenEXR library to make use
> > of this facility.
> >   Alternatively, you may use any of the following built-in formats: HDR.
> > Fatal error in parser: Cannot open file.
> > Render failed
> >
> > how does one do that?
> >
> > this is ubuntu 16.04  kernel 4.4.108, the following libraries are installed;
> >     libopenexr-dev
> >     libopenexr22
> >     openexr
> > and associated
> >     libilmbase-dev
> >     libilmbase12
> > all of these are version 2.2.0-10ubuntu2
> >
> > thank you.
> >
> >
> Did you compile them yourself ?
>
> Did you read the output of ./configure about openexr ?
> (not only the end, but when it search for openexr)
>
> (From my experience with Ubuntu 16.04, no problem to have openexr in
> povray, I have the output of "povray --version" to prove it)
>
> If it can help, I documented an even older version of ubuntu, when it
> was 3.7RC4 (yep, it's old):
>
> http://wiki.povray.org/content/User:Le_Forgeron/vault/Ubuntu_Gcc

thank you, this is what i needed.  the output of ./configure included
   checking whether to use the OpenEXR library... yes
   checking for pkg-config... no
   checking for OpenEXR's pkg-config... not found
trying to add pkg-config with synaptic showed it was broken.  it seemed to need
dpkg-dev, which in turn would not install due to needing libdpkg-perl, which was
somehow a slightly wrong version.  reinstalling libdpkg-perl, it went from
1.18.4ubuntu1.2 to 1.18.4ubuntu1, which fixed everything.

thanks again


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.