POV-Ray : Newsgroups : povray.binaries.tutorials : Re: Where are my lights???? Server Time
1 Mar 2024 17:09:22 EST (-0500)
  Re: Where are my lights???? (Message 1 to 2 of 2)  
From: Ken
Subject: Re: Where are my lights????
Date: 9 Apr 1999 01:37:44
Message: <370D82E5.175D0F9A@pacbell.net>
Hi,

  I took a look at your scene file and think I can explain your
proceedural misunderstanding. I would have tried rendering it
after making some changes but I am rendering a scene while on line
and don't want to stop it right now.
  You have each of your disks located at y = 0. You also have a
couple of cylinders at y = 0 that are at least 1/2 a pov unit thick
(I didn't memorize all of the paramaters of your scene so bear with
me on my generalizations}. Now you have added several cylinder light
sources ringing this construction all at a uniform distance of 80 units
or so and each is lying on the y = 0 zero plane. All I can tell you is
that in pov, as it is in real life, light cannot travel through solid
objects and that is what you are expecting them to do with the current
arrangement. Add a positive y value to your light statements and they
should start to work. I am almost certain that is your problem.

They are specified now as:

 light_source { <0, 0, 80 > stuff }

Try changing them to:

 light_source { <0, 3, 80 > stuff }

and see if that makes a difference in their perfomance.

Also when I checked to see what camera position you are using
I noticed that you have your camera at:

camera { location < 0, 200, 0 > look_at <0,0,0>}

You are very lucky that this alone is not crashing the program. In
most cases it causes a divide by zero error and the program terminates
with a program fualt. Even if you are getting away with it now it is not
a good practice to continue. If you need a straight overhead position
like this always add a very small amount of -z to the camera location.

Example:
camera { location < 0, 200, -0.0001 > look_at <0,0,0>}

That very tiny amount will keep the program from having the divide by
zero problem and will in all but the most extreme cases be totaly
undetectable in the way the scene looks when rendered.


-- 
Ken Tyler

mailto://tylereng@pacbell.net


Post a reply to this message

From: Dave Helfrich
Subject: Re: Where are my lights????
Date: 9 Apr 1999 23:50:45
Message: <370ebc85.0@news.povray.org>
Thanks for the tips...
First of all though, the cylinders that the lights fall in are (supposedly)
clear.  I tried using the "no_shadow" option on them as well, to no avail.

The center is a series of concentric discs, immediately followed by a thin
ring (difference of 2 cylinders.)  The outer most ring is also a difference
of 2 cylinders.  The large ring between them is actually a cylinder, <0, -3,
0>, <0, 1, 0> that is differenced from a plane (y= -0.5).  The large ring
does have a texture because I didn't want the green of the plane to show
there.  But if it's got the "no_shadow" option on it, why wouldn't the
lights shine through?  I think I'm going to try to give that large inner
ring a clear texture and see if that helps.

Secondly, I also tried raising the light sources up along the y axis.. as
high as y=10, which should have taken them well above any of the rings.
Still didn't help.

Thirdly, the camera angle I used in this was so I could get a "bird's eye"
view of the scene.  I don't generally render scenes at that angle...  I do
it on occasion just to get a look at how things are placed when I'm having
difficulties (as I was with this one).  I haven't had any problems yet doing
that.

There are actually more objects in this scene, but I commented them out
while in an attempt to isolate what was blocking the light sources.  When I
sent the sample code, I didn't include those objects.  (Otherwise there'd be
something like 500 or so lines of code commented out.)

Thanks for your tips...  I'll play with it some more and see what I can do.

--Dave

Ken wrote in message <370D82E5.175D0F9A@pacbell.net>...
>Hi,
>
>  I took a look at your scene file and think I can explain your
>proceedural misunderstanding. I would have tried rendering it
>after making some changes but I am rendering a scene while on line
>and don't want to stop it right now.
>  You have each of your disks located at y = 0. You also have a
>couple of cylinders at y = 0 that are at least 1/2 a pov unit thick
>(I didn't memorize all of the paramaters of your scene so bear with
>me on my generalizations}. Now you have added several cylinder light
>sources ringing this construction all at a uniform distance of 80 units
>or so and each is lying on the y = 0 zero plane. All I can tell you is
>that in pov, as it is in real life, light cannot travel through solid
>objects and that is what you are expecting them to do with the current
>arrangement. Add a positive y value to your light statements and they
>should start to work. I am almost certain that is your problem.
>
>They are specified now as:
>
> light_source { <0, 0, 80 > stuff }
>
>Try changing them to:
>
> light_source { <0, 3, 80 > stuff }
>
>and see if that makes a difference in their perfomance.
>
>Also when I checked to see what camera position you are using
>I noticed that you have your camera at:
>
>camera { location < 0, 200, 0 > look_at <0,0,0>}
>
>You are very lucky that this alone is not crashing the program. In
>most cases it causes a divide by zero error and the program terminates
>with a program fualt. Even if you are getting away with it now it is not
>a good practice to continue. If you need a straight overhead position
>like this always add a very small amount of -z to the camera location.
>
>Example:
>camera { location < 0, 200, -0.0001 > look_at <0,0,0>}
>
>That very tiny amount will keep the program from having the divide by
>zero problem and will in all but the most extreme cases be totaly
>undetectable in the way the scene looks when rendered.
>
>
>--
>Ken Tyler
>
>mailto://tylereng@pacbell.net


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.