POV-Ray : Newsgroups : povray.unix : Packaging povray 3.7 stable for Arch Linux Server Time: 26 Jul 2017 14:46:11 GMT
  Packaging povray 3.7 stable for Arch Linux (Message 1 to 10 of 13)  
Goto Latest 10 Messages Next 3 Messages >>>
From: xyproto
Subject: Packaging povray 3.7 stable for Arch Linux
Date: 11 Nov 2013 16:00:01
Message: <web.5280fbd39c90a98b1f457b8f0@news.povray.org>
Hi,


I'm the current maintainer of the povray package in Arch Linux. Right now, I'm
trying to package povray 3.7 stable, but I have encountered several issues.

I'm on 64-bit Arch Linux.

Here is what I've tried:

* Downloading https://github.com/POV-Ray/povray/archive/3.7-stable.zip
  (md5sum 773192125d7c8326c6b730a3aba44318)
* unzip 3.7-stable.zip
* cd povray-3.7-stable
  (the norm for most other packages is to only call this directory
  pkgname-pkgver, btw. Example: povray-3.7).
* cd unix
* ./prebuild.sh
  (here is the resulting stdout: http://ix.io/8ZF and stderr: http://ix.io/8ZG)
* cd ..
* ./configure COMPILED_BY='Arch Linux' --prefix=/usr --sysconfdir=/etc
  (here is the resulting stdout: http://ix.io/8ZH and stderr: http://ix.io/8ZI )

This is the section where the configure script stops:

Libraries
---------
checking whether to link with cygwin DLL... no
checking whether to enable static linking... no
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking for boostlib >= 1.37... yes
checking whether the Boost::Thread library is available... yes
checking for exit in -lboost_thread... yes
checking whether the boost thread library is usable... no

These packages are installed:
boost 1.54.0-4
boost-libs 1.54.0-4
boost-build 2.0_m12-5

These library files named something with "boost_thread" are present:
/usr/lib/libboost_thread.so
/usr/lib/libboost_thread.so.1.54.0

These boost-related binary files are present:
/usr/bin/bcp
/usr/bin/bjam
/usr/bin/compiler_status
/usr/bin/inspect
/usr/bin/library_status
/usr/bin/process_jam_log
/usr/bin/quickbook
/usr/bin/wave

Specifically, there are no boost-related libraries available that has the "-mt"
suffix.


What can I do to get past this hurdle?


On an unrelated note, I have also tried forcing configure to continue even
though the boost library is supposedly unusable, but then other issues appears,
related to not finding various Makefile.in files when compiling.


Thanks in advance.


Best regards,
Alexander Rødseth


Post a reply to this message

From: LanuHum
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 11 Nov 2013 16:30:01
Message: <web.52810591323e085d7a3e03fe0@news.povray.org>
Sorry!
This is problem in Mageia-3 64-bit and Ubuntu 13.10 64-bit
Mageia-3 file povray.spec for Povray-3.7-RC7 in Povray-3.7-pelease not work:
%configure2_5x --with-x COMPILED_BY="%_vendor" --disable-optimiz
--with-boost-libdir=%{_libdir}


Post a reply to this message

From: Le Forgeron
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 11 Nov 2013 16:48:35
Message: <52810a63$1@news.povray.org>
Le 11/11/2013 16:59, xyproto nous fit lire :
> Hi,
> 
> 
> I'm the current maintainer of the povray package in Arch Linux. Right now, I'm
> trying to package povray 3.7 stable, but I have encountered several issues.
> 
> I'm on 64-bit Arch Linux.
> 
> Here is what I've tried:
> 
> * Downloading https://github.com/POV-Ray/povray/archive/3.7-stable.zip
>   (md5sum 773192125d7c8326c6b730a3aba44318)
> * unzip 3.7-stable.zip
> * cd povray-3.7-stable
>   (the norm for most other packages is to only call this directory
>   pkgname-pkgver, btw. Example: povray-3.7).
> * cd unix
> * ./prebuild.sh
>   (here is the resulting stdout: http://ix.io/8ZF and stderr: http://ix.io/8ZG)
> * cd ..
> * ./configure COMPILED_BY='Arch Linux' --prefix=/usr --sysconfdir=/etc
>   (here is the resulting stdout: http://ix.io/8ZH and stderr: http://ix.io/8ZI )
> 
> This is the section where the configure script stops:
> 
> Libraries
> ---------
> checking whether to link with cygwin DLL... no
> checking whether to enable static linking... no
> checking for the pthreads library -lpthreads... no
> checking whether pthreads work without any flags... no
> checking whether pthreads work with -Kthread... no
> checking whether pthreads work with -kthread... no
> checking for the pthreads library -llthread... no
> checking whether pthreads work with -pthread... yes
> checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
> checking if more special flags are required for pthreads... no
> checking for boostlib >= 1.37... yes
> checking whether the Boost::Thread library is available... yes
> checking for exit in -lboost_thread... yes
> checking whether the boost thread library is usable... no
> 
> These packages are installed:
> boost 1.54.0-4
> boost-libs 1.54.0-4
> boost-build 2.0_m12-5
> 
> These library files named something with "boost_thread" are present:
> /usr/lib/libboost_thread.so
> /usr/lib/libboost_thread.so.1.54.0
> 
> These boost-related binary files are present:
> /usr/bin/bcp
> /usr/bin/bjam
> /usr/bin/compiler_status
> /usr/bin/inspect
> /usr/bin/library_status
> /usr/bin/process_jam_log
> /usr/bin/quickbook
> /usr/bin/wave
> 
> Specifically, there are no boost-related libraries available that has the "-mt"
> suffix.
> 
> 
> What can I do to get past this hurdle?
> 

With modern boost (past 1.49 i believe), you need to have
 LIBS="-lboost_system -lboost_thread"
as additional parameter of configure.

and of course the *-dev version of libraries (only to compile), if
that's relevant to your architecture (I do not know Arch, only Ubuntu)

> Best regards,
> Alexander Rødseth
> 
> 
Best regards, and thanks for your work.


Post a reply to this message

From: clipka
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 11 Nov 2013 21:00:53
Message: <52814585$1@news.povray.org>
Am 11.11.2013 16:59, schrieb xyproto:

> * Downloading https://github.com/POV-Ray/povray/archive/3.7-stable.zip
>    (md5sum 773192125d7c8326c6b730a3aba44318)
> * unzip 3.7-stable.zip
> * cd povray-3.7-stable
>    (the norm for most other packages is to only call this directory
>    pkgname-pkgver, btw. Example: povray-3.7).

Let's rephrase this: "The norm for most /Linux/ packages is..." ;-)

It should be noted that the POV-Ray software package is not a Unix or 
Linux package. It is an essentially platform-independent package, that 
happens to include both a Unix and a Windows port.

There are plans to make available a Unix-specific package in some way or 
another, which will be more easily palatable for the Linux community, 
but that hasn't happened yet for 3.7.0. At the moment we're relying on 
Unix package maintainers like you to bridge the few - hopefully minor - 
gaps you're seeing.


Post a reply to this message

From: xyproto
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 12 Nov 2013 22:05:00
Message: <web.5282a5fd323e085db48ed74f0@news.povray.org>
Hi,


Thank you for the replies!

Good point about povray not specifically targeting Linux.


Adding LIBS="-lboost_system -lboost_thread" was the right incantation for
getting one step further in the configuration process.


I'm using the exact steps as described above, but now using this configure line
instead:

 ./configure LIBS="-lboost_system -lboost_thread" COMPILED_BY='Arch Linux'
--prefix=/usr --sysconfdir=/etc --with-boost-thread=boost_thread


However, the configuration script now stops at this point in the process:


Makefiles
---------
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: error: cannot find input file: `Makefile.in'


Further assistance is appreciated.


- Alexander


Post a reply to this message

From: Le Forgeron
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 12 Nov 2013 23:22:39
Message: <5282b83f$1@news.povray.org>
Le 12/11/2013 23:04, xyproto nous fit lire :
> 
> Hi,
> 
> 
> Thank you for the replies!
> 
> Good point about povray not specifically targeting Linux.
> 
> 
> Adding LIBS="-lboost_system -lboost_thread" was the right incantation for
> getting one step further in the configuration process.
> 
> 
> I'm using the exact steps as described above, but now using this configure line
> instead:
> 
>  ./configure LIBS="-lboost_system -lboost_thread" COMPILED_BY='Arch Linux'
> --prefix=/usr --sysconfdir=/etc --with-boost-thread=boost_thread
> 
> 
> However, the configuration script now stops at this point in the process:
> 
> 
> Makefiles
> ---------
> checking that generated files are newer than configure... done
> configure: creating ./config.status
> config.status: error: cannot find input file: `Makefile.in'
> 
> 


Failing to reproduce on my Ubuntu 13.10: I reach

===============================================================================
POV-Ray 3.7.0 has been configured.

Built-in features:
  I/O restrictions:          enabled
  X Window display:          enabled (using SDL)
  Supported image formats:   gif tga iff ppm pgm hdr png jpeg tiff openexr
  Unsupported image formats: -

Compilation settings:
  Build architecture:  x86_64-unknown-linux-gnu
  Built/Optimized for: x86_64-unknown-linux-gnu (using -march=native)
  Compiler vendor:     gnu
  Compiler version:    g++ 4.8
  Compiler flags:      -pipe -Wno-multichar -Wno-write-strings
-fno-enforce-eh-specs -s -O3 -ffast-math -march=native -pthread

Type 'make check' to build the program and run a test render.
Type 'make install' to install POV-Ray on your system.

The POV-Ray components will be installed in the following directories:
  Program (executable):       /usr/bin
  System configuration files: /etc/povray/3.7
  User configuration files:   /home/jerome/.povray/3.7
  Standard include files:     /usr/share/povray-3.7/include
  Standard INI files:         /usr/share/povray-3.7/ini
  Standard demo scene files:  /usr/share/povray-3.7/scenes
  Documentation (text, HTML): /usr/share/doc/povray-3.7
  Unix man page:              /usr/share/man





> Further assistance is appreciated.
> 

Makefile.in are generated by prebuild.sh, so maybe you do not have the
needed packages installed ?

Is automake available and working ? (there is a check at the beginning
of script for the version, 1.9+ is required, I have 1.13.3)



My steps were:

> * wget https://github.com/POV-Ray/povray/archive/3.7-stable.zip
> * md5sum 3.7-stable.zip
>   773192125d7c8326c6b730a3aba44318
> * unzip 3.7-stable.zip
> * cd povray-3.7-stable/unix
> * ./prebuild.sh
> * cd ..
> * ./configure COMPILED_BY="Jérôme Grimbert" LIBS="-lboost_system -lboost_thread"
--prefix=/usr --sysconfdir=/etc --with-boost-thread=boost_thread

Notice that with LIBS, the --with-boost-thread might be not needed.



> 
> - Alexander
> 
> 

Hereafter the end of output of prebuild.sh (note: truncated ):

Create ../doc/html
Create ./Makefile.am
Create ../kde_install.sh
Create ../povray.ini.in
Create ../Makefile.am
Create ../bootstrap
Create ../source/Makefile.am
Create ../vfe/Makefile.am
Run ../bootstrap
+ rm -f config.log config.status
+ aclocal -I .
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ autoheader --warnings=all
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ automake --warnings=all
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
/usr/share/automake-1.13/am/library.am: warning: 'libpovray.a': linking
libraries using a non-POSIX
/usr/share/automake-1.13/am/library.am: archiver requires 'AM_PROG_AR'
in 'configure.ac'
source/Makefile.am:32:   while processing library 'libpovray.a'
/usr/share/automake-1.13/am/library.am: warning: 'libvfe.a': linking
libraries using a non-POSIX
/usr/share/automake-1.13/am/library.am: archiver requires 'AM_PROG_AR'
in 'configure.ac'
vfe/Makefile.am:32:   while processing library 'libvfe.a'
+ autoconf --warnings=all
configure.ac:295: warning: The macro `AC_LANG_SAVE' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/lang.m4:125: AC_LANG_SAVE is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_LANG_C' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/c.m4:72: AC_LANG_C is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_TRY_LINK' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/general.m4:2687: AC_TRY_LINK is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_LANG_RESTORE' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/lang.m4:134: AC_LANG_RESTORE is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ cat ./configure
+ sed -e s,configure.gnu  --help=recursive,& --srcdir=$ac_srcdir,g -e
s,\(cd \)\($ac_\)\(pop\)*\(dir\),\1"\2\3\4",g -e
s,$am_aux_dir/missing,\\"$am_aux_dir\\"/missing,g
+ mv -f ./configure.tmp ./configure
+ chmod +x ./configure
+ rm -f -r ./autom4te.cache


Post a reply to this message

From: xyproto
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 13 Nov 2013 00:55:00
Message: <web.5282cd0e323e085db48ed74f0@news.povray.org>
Hi,


Even after removing "--with-boost-thread=boost_thread", the result is the same.

All packages from the "base" and "base-devel" package groups are installed. Here
are the version numbers (and package release numbers after the dash) for the
packages in base-devel. These are all installed on my system:

autoconf 2.69-1
automake 1.14-1
bison 3.0-1
fakeroot 1.20-1
file 5.15-1
findutils 4.4.2-5
flex 2.5.37-1
gawk 4.1.0-2
gcc 4.8.2-4
gettext 0.18.3.1-2
grep 2.15-1
groff 1.22.2-5
gzip 1.6-1
libtool 2.4.2-12
m4 1.4.17-1
make 4.0-1
pacman 4.1.2-4
patch 2.7.1-2
pkg-config 0.28-1
sed 4.2.2-3
sudo 1.8.8-1
texinfo 5.2-2
util-linux 2.24-1
which 2.20-6


The error is still:

config.status: error: cannot find input file: `Makefile.in'

There does exist a Makefile.in file in the unix directory, but it is empty (has
a size of 0 bytes).


- Alexander


Post a reply to this message

From: Le Forgeron
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 13 Nov 2013 06:54:07
Message: <5283220f$1@news.povray.org>
Le 13/11/2013 01:51, xyproto a écrit :
> 
> Hi,
> 
> 
> Even after removing "--with-boost-thread=boost_thread", the result is the same.
> 
> All packages from the "base" and "base-devel" package groups are installed. Here
> are the version numbers (and package release numbers after the dash) for the
> packages in base-devel. These are all installed on my system:
> 

My bad.

Please compare your error output of prebuild.sh with my previous
truncated copy: it seems automake 1.14 is not happy. Maybe you need some
option(s) to put in compatibility mode with 1.9 (like subdir-objects ?)

Yet another great evolution that broke random bits.

> 
> The error is still:
> 
> config.status: error: cannot find input file: `Makefile.in'
> 
> There does exist a Makefile.in file in the unix directory, but it is empty (has
> a size of 0 bytes).


-- 
Just because nobody complains does not mean all parachutes are perfect.


Post a reply to this message

From: xyproto
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 14 Nov 2013 18:25:01
Message: <web.52851550323e085db48ed74f0@news.povray.org>
Hi,

After configuring the configure scripts that configure configure before
compiling with make, it finally compiles!

These were the steps that ended up working for me:

cd unix
sed 's/automake --w/automake --add-missing --w/g' -i prebuild.sh
sed 's/dist-bzip2/dist-bzip2 subdir-objects/g' -i configure.ac
../prebuild.sh
cd ..
../bootstrap
../configure LIBS="-lboost_system -lboost_thread" COMPILED_BY='Arch Linux'
--prefix=/usr --sysconfdir=/etc
make CXXFLAGS+="-w -lboost_system -lboost_thread"

Thanks for all the help!

Best regards,
Alexander Rødseth


Post a reply to this message

From: xyproto
Subject: Re: Packaging povray 3.7 stable for Arch Linux
Date: 14 Nov 2013 20:30:01
Message: <web.528531d8323e085db48ed74f0@news.povray.org>
Don't know why ./configure where changed to ../configure when I posted. Just to
clarify, there is only supposed to be one dot, like this: ./configure.


Post a reply to this message

Goto Latest 10 Messages Next 3 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.