POV-Ray : Newsgroups : povray.windows : Vs 2017 debug : Re: Vs 2017 debug Server Time
1 Dec 2021 05:12:05 EST (-0500)
  Re: Vs 2017 debug  
From: clipka
Date: 18 Feb 2018 07:21:43
Message: <5a896fd7$1@news.povray.org>
Am 18.02.2018 um 10:59 schrieb Havana7:
>> - Can you successfully place breakpoints in the GUI version?
> 
> No the window does not open and no breckpoint works

Can you successfully run the GUI debug version /without/ breakpoints set?

Either way, as long as you are having trouble running or debugging even
the GUI version of POV-Ray, it does not make sense trying to run or
debug the console version.

Since running and debugging the GUI version of POV-Ray in VS 2015 is a
routine thing and I'm not seeing any problems there, I suspect this to
be a problem specific to VS 2017, or even your installation thereof. I'd
therefore recommend seeking assistance from Microsoft or their community.

If running POV-Ray without breakpoints works fine, maybe the breakpoints
do work but the VS 2017 debugger isn't kicking in properly to take you
to the code being executed. That would explain the symptoms you are
reporting.


> I have a breackpoint in vfe / win / console / winconsole.cpp Main, I clean the
> solution, compile it and start debugging.
> 
> Nothing happens.

Try a breakpoint later in the program flow; I'd recommend
`parser_tokenizer.cpp`, about line 2633, right after
`CASE(DEBUG_TOKEN)`. This should cause the breakpoint to only be
triggered when a `#debug` statement in the scene file (or include file)
is encountered.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.