POV-Ray : Newsgroups : povray.unofficial.patches : UberPOV v1.37.1.0-beta.9 released Server Time
6 Dec 2022 08:15:15 EST (-0500)
  UberPOV v1.37.1.0-beta.9 released (Message 7 to 16 of 16)  
<<< Previous 6 Messages Goto Initial 10 Messages
From: clipka
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 31 Jan 2015 22:10:57
Message: <54cd9941$1@news.povray.org>
Am 01.02.2015 um 02:49 schrieb James Holsenback:

>> and noticed the checking whether g++ accepts yada-yada shows up for the
>> beta9 configure ... is that a clue?
>
> Oh ... and the Compiler flags shows -Wno-non-template-friend for b9 as well

Nope (presuming with "yada-yada" you mean "-Wno-non-template-friend"); 
this is just the suppression of an unwarranted warning from g++. 
Effectively, what this is all about is that there was a quirk in older 
g++ versions violating the C++ specs, and now by default they issue a 
warning just in case your code was relying on g++'s old behaviour.

I'll have a closer look at it. It's certainly not something affecting 
the Windows build.


Post a reply to this message

From: clipka
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 31 Jan 2015 22:37:39
Message: <54cd9f83$1@news.povray.org>
Am 01.02.2015 um 02:26 schrieb James Holsenback:

> Same error that I'm getting with ANY source AFTER beta6 (which built
> just fine)

Can you please do me a favor and check again with the following versions:

     ce0aae6b54d434ceb3daf7410582f95ea742ac14 (2014-07-27)
     e1028cd0dbb0918324cf9b898906b54222fc67da (2014-07-29)

I have strong reason to believe that the latter introduced the error. 
Which also means that it's probably already present in the 
feature/colour_model branch in the official POV-Ray repo.


Post a reply to this message

From: James Holsenback
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 31 Jan 2015 23:08:01
Message: <54cda6a1$1@news.povray.org>
On 01/31/2015 10:37 PM, clipka wrote:
> Am 01.02.2015 um 02:26 schrieb James Holsenback:
>
>> Same error that I'm getting with ANY source AFTER beta6 (which built
>> just fine)
>
> Can you please do me a favor and check again with the following versions:
>
>      ce0aae6b54d434ceb3daf7410582f95ea742ac14 (2014-07-27)
>      e1028cd0dbb0918324cf9b898906b54222fc67da (2014-07-29)
>
> I have strong reason to believe that the latter introduced the error.
> Which also means that it's probably already present in the
> feature/colour_model branch in the official POV-Ray repo.
>

ce0aae6b54d434ceb3daf7410582f95ea742ac14 has the same error so I did NOT 
pull e1028cd0dbb0918324cf9b898906b54222fc67da


Post a reply to this message

From: clipka
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 1 Feb 2015 00:14:27
Message: <54cdb633@news.povray.org>
Am 01.02.2015 um 05:08 schrieb James Holsenback:
> On 01/31/2015 10:37 PM, clipka wrote:
>> Am 01.02.2015 um 02:26 schrieb James Holsenback:
>>
>>> Same error that I'm getting with ANY source AFTER beta6 (which built
>>> just fine)
>>
>> Can you please do me a favor and check again with the following versions:
>>
>>      ce0aae6b54d434ceb3daf7410582f95ea742ac14 (2014-07-27)
>>      e1028cd0dbb0918324cf9b898906b54222fc67da (2014-07-29)
>>
>> I have strong reason to believe that the latter introduced the error.
>> Which also means that it's probably already present in the
>> feature/colour_model branch in the official POV-Ray repo.
>>
>
> ce0aae6b54d434ceb3daf7410582f95ea742ac14 has the same error so I did NOT
> pull e1028cd0dbb0918324cf9b898906b54222fc67da

Strange - I suspect you must have done something wrong there. Never 
mind, I've been able to reproduce the error and trace it back to the 
"feature/colour_model" branch in the official repo (which is what 
UberPOV is based on). I'm currently in the process of releasing a fix.


Post a reply to this message

From: clipka
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 1 Feb 2015 00:56:53
Message: <54cdc025$1@news.povray.org>
Am 31.01.2015 um 09:47 schrieb clipka:
> Latest UberPOV version, with all the new official POV-Ray bells &
> whistles merged in.
>
> https://github.com/UberPOV/UberPOV/releases/tag/v1.37.1.0-beta.9

As Jim has pointed out, beta.9 doesn't compile on Linux, so here's a 
source code update:

https://github.com/UberPOV/UberPOV/releases/tag/v1.37.1.0-beta.9b


Post a reply to this message

From: James Holsenback
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 1 Feb 2015 01:23:58
Message: <54cdc67e$1@news.povray.org>
On 02/01/2015 12:56 AM, clipka wrote:
> Am 31.01.2015 um 09:47 schrieb clipka:
>> Latest UberPOV version, with all the new official POV-Ray bells &
>> whistles merged in.
>>
>> https://github.com/UberPOV/UberPOV/releases/tag/v1.37.1.0-beta.9
>
> As Jim has pointed out, beta.9 doesn't compile on Linux, so here's a
> source code update:
>
> https://github.com/UberPOV/UberPOV/releases/tag/v1.37.1.0-beta.9b
>

yer gettin' closer:

backend/povray.cpp: In function ‘void 
{anonymous}::BuildInitInfo(POVMSObjectPtr)’:
backend/povray.cpp:301:115: error: expected ‘)’ before ‘SSE2_INCLUDED’


Post a reply to this message

From: clipka
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 1 Feb 2015 01:39:00
Message: <54cdca04$1@news.povray.org>
Am 01.02.2015 um 07:23 schrieb James Holsenback:

> yer gettin' closer:
>
> backend/povray.cpp: In function ‘void
> {anonymous}::BuildInitInfo(POVMSObjectPtr)’:
> backend/povray.cpp:301:115: error: expected ‘)’ before ‘SSE2_INCLUDED’

Strangely enough, I didn't come across that one on my Linux machine.
Are you building on a 32 bit computer?

Until I figure this one out, I recommend you just remove the 
"SSE2_INCLUDED" from that line (any anywhere else where it might cause 
hiccups).


Post a reply to this message

From: James Holsenback
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 1 Feb 2015 01:46:53
Message: <54cdcbdd$1@news.povray.org>
On 02/01/2015 01:38 AM, clipka wrote:
> Am 01.02.2015 um 07:23 schrieb James Holsenback:
>
>> yer gettin' closer:
>>
>> backend/povray.cpp: In function ‘void
>> {anonymous}::BuildInitInfo(POVMSObjectPtr)’:
>> backend/povray.cpp:301:115: error: expected ‘)’ before ‘SSE2_INCLUDED’
>
> Strangely enough, I didn't come across that one on my Linux machine.
> Are you building on a 32 bit computer?

yes

>
> Until I figure this one out, I recommend you just remove the
> "SSE2_INCLUDED" from that line (any anywhere else where it might cause
> hiccups).
>

was already in the file trying to make repair when i saw your reply ... 
line 301 was the only place


Post a reply to this message

From: Doctor John
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 1 Feb 2015 09:15:37
Message: <54ce3509$1@news.povray.org>
On 01/02/15 06:38, clipka wrote:
> Am 01.02.2015 um 07:23 schrieb James Holsenback:
> 
>> yer gettin' closer:
>>
>> backend/povray.cpp: In function ‘void
>> {anonymous}::BuildInitInfo(POVMSObjectPtr)’:
>> backend/povray.cpp:301:115: error: expected ‘)’ before ‘SSE2_INCLUDED’
> 
> Strangely enough, I didn't come across that one on my Linux machine.
> Are you building on a 32 bit computer?
> 
> Until I figure this one out, I recommend you just remove the
> "SSE2_INCLUDED" from that line (any anywhere else where it might cause
> hiccups).
> 

It appears that removing SSE_INCLUDED from line 301 in
backend/povray.cpp does the trick.

I got the same error as James but I was compiling on a 64 bit machine.
After removal of offending word, all is sweetness and light

John
-- 
Protect the Earth
It was not given to you by your parents
You hold it in trust for your children


Post a reply to this message

From: Doctor John
Subject: Re: UberPOV v1.37.1.0-beta.9 released
Date: 1 Feb 2015 10:29:32
Message: <54ce465c$1@news.povray.org>
On 01/02/15 14:15, Doctor John wrote:
> 
> I got the same error as James but I was compiling on a 64 bit machine.
> After removal of offending word, all is sweetness and light
> 
> John
> 

Additional:
john@linux-bh1u:~> gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib64/gcc/x86_64-suse-linux/4.8/lto-wrapper
Target: x86_64-suse-linux
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info
--mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64
--enable-languages=c,c++,objc,fortran,obj-c++,java,ada
--enable-checking=release --with-gxx-include-dir=/usr/include/c++/4.8
--enable-ssp --disable-libssp --disable-plugin
--with-bugurl=http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux'
--disable-libgcj --disable-libmudflap --with-slibdir=/lib64
--with-system-zlib --enable-__cxa_atexit
--enable-libstdcxx-allocator=new --disable-libstdcxx-pch
--enable-version-specific-runtime-libs --enable-linker-build-id
--enable-linux-futex --program-suffix=-4.8 --without-system-libunwind
--with-arch-32=i586 --with-tune=generic --build=x86_64-suse-linux
--host=x86_64-suse-linux
Thread model: posix
gcc version 4.8.3 20140627 [gcc-4_8-branch revision 212064] (SUSE Linux)

John
-- 
Protect the Earth
It was not given to you by your parents
You hold it in trust for your children


Post a reply to this message

<<< Previous 6 Messages Goto Initial 10 Messages

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.