POV-Ray : Newsgroups : povray.unofficial.patches : qtpovray v3.80.8 for Linux : Re: qtpovray v3.80.8 for Linux Server Time
7 Jul 2022 04:35:19 EDT (-0400)
  Re: qtpovray v3.80.8 for Linux  
From: dick balaska
Date: 21 Sep 2018 16:48:31
Message: <5ba5591f$1@news.povray.org>
On 09/21/2018 03:35 AM, Mike Horvath wrote:
> On 9/20/2018 11:27 PM, dick balaska wrote:
>> qtpovray (3.80.8~xenial1) xenial; urgency=low
> 
> Do you plan to port the qt frontend to Windows?

Yes.  In fact, the frontend works on Windows. ;)
My first foray was "qtpov", a Qt gui that launched a custom povray that
used websockets instead of a command line. That ran on Windows and
Linux.  That gui is the qtpovray frontend.

My problem is with building povray with qmake (Qt's ./configure
replacement).  It all works great on Linux, but, on Windows, I have a
problem with a master project that has two library subprojects plus an
executable subproject.  (It tries to build the second library skipping
the "compile the source" bits, thus tipping over because the .obj files
don't exist).  I'll get to it at some point.

My Windows experience these days is limited to a 1024x768 window in my
Linux desktop.  VS2015 and QtCreator are pretty laughable at that size.
Ain't nobody wanna deal with that.
> 
> 
> Mike


-- 
dik
Rendered 1024 of 921600 pixels (0%)


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.