POV-Ray : Newsgroups : povray.unix : Installation incomplete for github downloaded 3.7 : Installation incomplete for github downloaded 3.7 Server Time
18 Sep 2021 04:03:20 EDT (-0400)
  Installation incomplete for github downloaded 3.7  
From: wealthychef
Date: 24 Jul 2014 20:00:01
Message: <web.53d19d1323f0eff3784e7dc60@news.povray.org>
Hi, it looks as though if I want to install povray 3.7 on our linux cluster, the
right thing to do is go to the github repo, click "download zip" and then build
from there.  So I did the following:

#!/usr/bin/env bash
export prefix=/usr/local/tools/povray-3.7

 unzip -f povray-3.7-stable.zip
 pushd povray-3.7-stable/unix
 ./prebuild.sh
 cd ..

     ./configure --prefix=${prefix} LIBS=-lm CC=gcc CXX=g++ FC=g77
COMPILED_BY="Rich Cook <rco### [at] llnlgov>"  LD_FLAGS='-lboost_filesystem-mt
-lboost-system-mt -lboost_thread-mt'  CXXFLAGS='-lboost_filesystem-mt
-lboost_system-mt -lboost_thread-mt' --with-libmkl=$MKL_DIR || cat config.log

        make -j 12
        make install

    popd

At the end of this process,  I'm left with a very barren $prefix directory.
There is nothing but a bin directory with povray in it, basically, no share or
other directories that used to get installed.  No include files or other library
resources.

What's the magic to do a proper install?
Thanks


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.