POV-Ray : Newsgroups : povray.unix : POV-Ray v3.8.0-beta.1 : Re: POV-Ray v3.8.0-beta.1 Server Time
20 Oct 2021 14:56:13 EDT (-0400)
  Re: POV-Ray v3.8.0-beta.1  
From: Thomas de Groot
Date: 29 Jul 2021 11:45:03
Message: <6102ccff$1@news.povray.org>
I still do not understand this parse warning as I do *not* run a version 
3.5 scene. Does it refer to POV-Ray includes which /mention/ version 3.5?
functions.inc seem to be the only include file containing this.

Just a short explanation would be enough about this mysterious warning.

Thanks,

Thomas

Op 19-7-2021 om 14:17 schreef Thomas de Groot:
> Rendering a 3.8 version scene which includes functions.inc, I get the 
> following parse warning:
> 
> "functions.inc" line 167: Parse warning: use of POV-Ray v3.7 keyword 
> ('deprecated') detected in alleged v3.5 scene.
> 
> The only place were version 3.5 is mentioned is precisely at the start 
> of functions.inc:
> 
> #ifndef(Functions_Inc_Temp)
> #declare Functions_Inc_Temp = version;
> #version 3.5;
> ...
> #end
> 
> At the mentioned line 167 of this /new/ functions.inc shipped with the 
> beta, a /new/ if statement has been introduced, not there in previous 
> versions:
> 
> #if (Functions_Inc_Temp < 3.8)
>      #declare deprecated once "f_enneper was broken prior to v3.8; 
> results will most likely differ."
>               f_enneper = function { internal(18) }
> #else
>      #declare f_enneper = function { internal(18) }
> #end
> 
> 


-- 
Thomas


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.