POV-Ray : Newsgroups : povray.unix : Freebsd : : Re: Freebsd : Server Time
28 Sep 2021 06:10:47 EDT (-0400)
  Re: Freebsd :  
From: clipka
Date: 28 Apr 2018 07:15:10
Message: <5ae457be$1@news.povray.org>
Am 28.04.2018 um 12:56 schrieb clipka:

> /usr/local/lib/compat/libstdc++.so.6: version CXXABI_1.3.9 required by
> /usr/home/tth/Softwares/povray-3.8.0-alpha.9606898/conftest not found
> 
> indicates that the compiler/linker chosen to build POV-Ray is building
> code for ABI version 1.3.9, which the C++ runtime library (libstdc++)
> installed on your machine does not support.

Thinking about this a bit more, I'm coming to doubt that's exactly
what's happening; otherwise the configure script should complain much
earlier, at the very moment it tests whether the C++ compiler works at all.

So with that in mind, it may actually be the boost shared libraries
(more specifically, `libbost_thread`, `libboost_system`, or both) which
require ABI 1.3.9 (meaning they were compiled for that ABI, so your
FreeBSD installation would be inconsistent and in a sense broken). So
maybe you need to look at those rather than the compiler.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.