POV-Ray : Newsgroups : povray.unix : no EXR in linux : Re: no EXR in linux Server Time
7 Dec 2021 17:29:54 EST (-0500)
  Re: no EXR in linux  
From: Le Forgeron
Date: 25 Apr 2018 08:47:10
Message: <5ae078ce$1@news.povray.org>
Le 25/04/2018 à 03:24, green a écrit :
> linux versions 3.7, 3.8 and uberpov will not write or read EXR file formats.
> trying to write gives a command-line-option error, whereas trying to read an EXR
> gives a more useful
> 
> This unofficial POV-Ray  binary was built without support for the OpenEXR file
> format.  You must either  use an official POV-Ray binary or recompile the
> POV-Ray sources on a system  providing you with the OpenEXR library to make use
> of this facility.
>   Alternatively, you may use any of the following built-in formats: HDR.
> Fatal error in parser: Cannot open file.
> Render failed
> 
> how does one do that?
> 
> this is ubuntu 16.04  kernel 4.4.108, the following libraries are installed;
>     libopenexr-dev
>     libopenexr22
>     openexr
> and associated
>     libilmbase-dev
>     libilmbase12
> all of these are version 2.2.0-10ubuntu2
> 
> thank you.
> 
> 
Did you compile them yourself ?

Did you read the output of ./configure about openexr ?
(not only the end, but when it search for openexr)

(From my experience with Ubuntu 16.04, no problem to have openexr in 
povray, I have the output of "povray --version" to prove it)

If it can help, I documented an even older version of ubuntu, when it 
was 3.7RC4 (yep, it's old):

http://wiki.povray.org/content/User:Le_Forgeron/vault/Ubuntu_Gcc


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.