POV-Ray : Newsgroups : povray.unix : ubuntu 16.04 burp : ubuntu 16.04 burp Server Time
22 Jun 2021 09:10:45 EDT (-0400)
  ubuntu 16.04 burp  
From: dick balaska
Date: 5 Feb 2017 03:46:14
Message: <5896e656$1@news.povray.org>
Apparently, I updated this box from ubuntu 14.04 to 16.04 last year, 
(since I last ran my renderfarm) and my homebuilt povray371 dies. (I'm 
ok with that)

$ git clone https://github.com/POV-Ray/povray.git
$ git checkout release/v3.7.1

$ cd unix ; ./prebuild.sh ; cd ..
$ ./configure BY="me"

checking whether to use the PNG library... yes
checking for library containing png_get_libpng_ver... no
configure: error: cannot find a suitable PNG library

No -lpng ? How odd.
Google says I want libpng12, which is what I have.

dig dig dig.

sudo apt-get install libpng-dev
sudo apt-get install libjpeg-dev
sudo apt-get install libtiff-dev

Wait. I saw a list somewhere someone had put together of these. Boy that 
would be helpful now.

$ make
$ unix/povray
...
and we're on our way
-- 
dik


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.