POV-Ray : Newsgroups : povray.unix : Unable to compile under Ubuntu 14.04 : Re: Unable to compile under Ubuntu 14.04 Server Time
20 Apr 2024 11:55:26 EDT (-0400)
  Re: Unable to compile under Ubuntu 14.04  
From: Le Forgeron
Date: 25 Mar 2014 15:56:36
Message: <5331df74$1@news.povray.org>
Le 25/03/2014 20:48, James Holsenback nous fit lire :
> On 03/25/2014 02:48 PM, Hadmut Danisch wrote:
>> Am 23.03.2014 07:35, schrieb Le_Forgeron:
>>
>>> Same old story, same workaround when using gcc compiler:
>>>
>>> ./configure ... LIBS="-lboost_system -lboost_thread"
>>
>>
>> Still lots of problems even before configure (fresh git checkout):
>>
>>
>> Detected autoconf 2.69
>> Detected automake 1.14.1
>>

> 
> did you run ~unix/prebuild.sh script first? if not cd to that (unix)
> directory and run it ... then pop back up one directory and try the
> configure phase again

It seems he did. But there might be an issue with automake (my version
here is 1.13.3 and all is fine, but I'm on 13.10 not 14.04 yet): see the
thread "Error building POV-Ray 3.7 on Linux (Debian Testing)", the error
was already there too.

Reported solution: running "automake --add-missing" on top directory
after prebuild.sh was ran, and running prebuild.sh again.

date of solution post: 22/11/2013, by Joel Yliluoma, :

> 
> The problem was eventually resolved by running "automake --add-missing"
> in the top directory _after_ prebuild.sh was run once, and then running
> prebuild.sh again...
> 
> This appeared to generate a symlink, compile->/usr/share/automake-1.14/compile
> in unix/config/ . Then it configured and compiled properly.
> 
> Why does this not happen otherwise?
> I have no idea.


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.