POV-Ray : Newsgroups : povray.tools.general : SharpConstruct with Windows & gtk+--installation problem : Re: SharpConstruct with Windows & gtk+--installation problem Server Time
29 May 2024 16:26:39 EDT (-0400)
  Re: SharpConstruct with Windows & gtk+--installation problem  
From: Kenneth
Date: 3 Jan 2010 12:35:00
Message: <web.4b40d43ad7af166a65f302820@news.povray.org>
Jaime Vives Piqueres <jai### [at] ignoranciaorg> wrote:

>    I think the program is not recognizing that your GTK version is newer than
> 2.8 (2.18 IS newer than 2.8). Considering SharpConstruct seems to have
> stopped development on 2006, and that 2.8 was indeed released that year, I
> think that's the case.
>
>    One solution will be to install the obsolete 2.8 version from here:
>
>    http://sourceforge.net/projects/gimp-win/files/Obsolete/
>

Thanks, Jaime. I gave that a good try. Unfortunately, *every* 2.8.xxx legacy
version of GTK+ that I downloaded there produces either the same error message
in SharpConstruct as before, or a new one:

"SharpConstruct needs the GTK part from the 'glade for windows' project, but you
seem to have the GTK part from the 'GIMP for Windows' project, which won't work.
See http://sharp.3d.sourceforge.net.... (a URL link that no longer works.)"

I went looking for such a thing, but haven't yet found it. The SharpConstruct
download page offers no information or clue to this either.

I'm guessing that the original Linux(?) version of the program must have been
more 'robust' than the later Windows port...that is, all the parts were better
integrated.

Given this impasse, I may *have* to download the latest version of Blender, if I
want the features of SharpConstruct. I don't know, though--Blender has its own
steep learning curve, from what I hear!

Ken


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.