POV-Ray : Newsgroups : povray.tools.general : SharpConstruct with Windows & gtk+--installation problem : Re: SharpConstruct with Windows & gtk+--installation problem Server Time
29 May 2024 16:49:07 EDT (-0400)
  Re: SharpConstruct with Windows & gtk+--installation problem  
From: Warp
Date: 4 Jan 2010 15:12:15
Message: <4b424b9f@news.povray.org>
Jaime Vives Piqueres <jai### [at] ignoranciaorg> wrote:
> > I'm guessing that the original Linux(?) version of the program must have
> > been more 'robust' than the later Windows port...that is, all the parts
> > were better integrated.

>    No, it's just that Linux usually has already installed most of what is
> needed for open source apps.

  Most distros have some kind of online repository system which automatically
resolves dependencies and installs any libraries which a program might need.

  In Windows programs usually come with all the libraries they need, and are
installed if not already installed in the system (or kept locally in the
program's own installation directory). However, many Windows ports of Unix
programs follow the "you should have this library already" philosophy, which
is why you often get such a hassle (which doesn't usually happen in linux,
at least if you are installing from a repository; it can still happen if
you are installing it manually, though).

-- 
                                                          - Warp


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.