POV-Ray : Newsgroups : povray.text.scene-files : Pigment is not showing up Server Time
27 Sep 2021 18:07:37 EDT (-0400)
  Pigment is not showing up (Message 1 to 4 of 4)  
From: Mike Horvath
Subject: Pigment is not showing up
Date: 13 May 2021 18:30:33
Message: <609da889$1@news.povray.org>
I am trying to multiply some pigments together and then apply them to a 
heightfield. However the render is blank. Compare pigment_5 (average) 
with pigment_6 (multiply). The latter is blank the former is not.

What am I doing wrong?

Render as a square image using this image as input:

https://en.wikipedia.org/wiki/File:Heightmap.png


Post a reply to this message


Attachments:
Download 'slopemap.pov.txt' (3 KB)

From: Mike Horvath
Subject: Re: Pigment is not showing up
Date: 13 May 2021 20:04:29
Message: <609dbe8d$1@news.povray.org>
On 5/13/2021 6:30 PM, Mike Horvath wrote:
> I am trying to multiply some pigments together and then apply them to a 
> heightfield. However the render is blank. Compare pigment_5 (average) 
> with pigment_6 (multiply). The latter is blank the former is not.
> 
> What am I doing wrong?
> 
> Render as a square image using this image as input:
> 
> https://en.wikipedia.org/wiki/File:Heightmap.png


The problem seems to be the slope pattern. It does not work when used in 
this manner. Other patterns are okay.


Mike


Post a reply to this message

From: Bald Eagle
Subject: Re: Pigment is not showing up
Date: 13 May 2021 20:40:00
Message: <web.609dc62d423561241f9dae3025979125@news.povray.org>
Mike Horvath <mik### [at] gmailcom> wrote:

> The problem seems to be the slope pattern. It does not work when used in
> this manner. Other patterns are okay.

Right, the slope pattern needs something to operate ON.  Otherwise what value
should the slope have?  The slope of WHAT?

http://news.povray.org/povray.advanced-users/thread/%3Cweb.5e9285d148d892ebfb0b41570%40news.povray.org%3E/


So, I think you're going to have to do it another way.
2 stage render?   1st using slope, then 2nd using that first render as an image
map?


Post a reply to this message

From: Mike Horvath
Subject: Re: Pigment is not showing up
Date: 13 May 2021 21:49:14
Message: <609dd71a$1@news.povray.org>
On 5/13/2021 8:37 PM, Bald Eagle wrote:
> So, I think you're going to have to do it another way.
> 2 stage render?   1st using slope, then 2nd using that first render as an image
> map?
> 
> 

Yes, thanks.


Mike


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.