POV-Ray : Newsgroups : povray.programming : OpenEXR 3.x issues - call to arms : Re: OpenEXR 3.x issues - call to arms Server Time
29 Jul 2021 05:25:45 EDT (-0400)
  Re: OpenEXR 3.x issues - call to arms  
From: jr
Date: 3 Jun 2021 09:35:00
Message: <web.60b8da01cb27e48a79819d986cde94f1@news.povray.org>
"jr" <cre### [at] gmailcom> wrote:
> ...
> my knowledge of the autotools is limited, ...

and so are my reading and comprehension, at times, evidently.


> Fix the Unix build process to do the right kind of version checking
> and pulling-in of libraries (primarily relevant files:
> `unix/configure.ac` and `unix/config/ax_check_openexr.m4`). The test for
> the actual `IlmImf` library would have to be changed, to test for
> `OpenEXR` instead if the version number detected is 3.0 or higher; also
> in that case, a test for the `Imath` library would have to be performed,
> which we currently don't have because it was effectively implicit when
> OpenEXR was present.

confused by your point (2) since 'Imath' is part of version 2.2.0 (and 1.7.1)
already.


regards, jr.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.