POV-Ray : Newsgroups : povray.programming : qtpovray and debian : Re: qtpovray and debian Server Time
2 Dec 2022 11:53:32 EST (-0500)
  Re: qtpovray and debian  
From: jr
Date: 28 Jun 2018 12:40:01
Message: <web.5b350f331b94875a635cc5ad0@news.povray.org>
hi,

dick balaska <dic### [at] buckosoftcom> wrote:
> > editor/codeeditor.cpp:112:8: error: ‘class CodeEditor’ has no member > Sorry
about that. I actually fixed that 
(debian defaults to an older
> "official" version of Qt) but I didn't push the changes back to github.
> Try it now.
> Also note the repo changed names.
>
> git clone https://github.com/dickbalaska/qtpovray.git
> cd qtpovray
> git checkout qtpovray
> qmake
> make -j4

thank you, both for the whole thing + the renaming.
now works as expected.

> qt/gui/qtpovray        # run the executable

ah, yes.  another problem, afraid to say..

start 'qtpovray', open a scene file, looks ok in editor, click the green arrow,
and:

  chdir:  /home/jr/wip/pov/media
  command:

appears in Consoles.POV-Ray box, and the following is appended to the Xserver's
log:

[12:47:59.570] WARN unhandled message: command: "stream fatal " text: "No input
file provided" ((null):0)
[12:47:59.570] WARN ErrorExit:  "No input file provided" ((null):0)

no other, discernable activity.  [raised eyebrow emoji, if I knew it]

from the 'qtpov.ini':

[General]
recentWorkspaces=/home/jr/.cache/qtpovray/b.pws

[EditorColors]

[Keys]

[Preferences]
PovrayExecutable=/usr/local/bin/povray380a
PovrayIncludes=/usr/local/share/povray-3.8/include
PovrayInsertMenu=


no idea what a "PovrayInsertMenu" is, is it needed?

>  >> BTW, I am running two VMs for testing right now, Ubuntu 16 and Ubuntu
>  >> 18.  I've thought about spinning up a Slackware 14.1 because of you. :)
>  >
>  > :-)  maybe that's a subconscious .. yearning for the old days.  ;-)
>
> Yeah, I miss working for hours to get an integrated apache/php/ssl chain
> (or postfix/dovecot/ssl).  Typing "sudo apt upgrade" is too easy.

</grin>

> I stuck with slackware for so long because, loyalty, and because I
> wanted to be more intimate with those tools.  These days, I just want it
> to work. :)
>  > if you do make it 14.2 though, which most use.  apparently, 15.0 is a
>  > possibility for later this year.
> I thought of that. But my google says 14.2 uses qt-5.6.1 (or 5.7.1 or
> 5.9.5)  The main reason for the exercise would be to build with qt-4.8 .

ok.  I'll be happy to test building here should you decide to go for it


regards, jr.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.