POV-Ray : Newsgroups : povray.programming : qtpovray and debian : Re: qtpovray and debian Server Time
27 Sep 2022 13:39:41 EDT (-0400)
  Re: qtpovray and debian  
From: jr
Date: 22 Jun 2018 18:35:00
Message: <web.5b2d77af1b94875a635cc5ad0@news.povray.org>
"jr" <cre### [at] gmailcom> wrote:
> clipka <ano### [at] anonymousorg> wrote:
> > > g++ ...
> > ... you need to smuggle a `-std=c++11` or `-std=gnu++11` into the g++ command
line. ...

spot on.  adding that option allows the process to progress until make enters
the 'qt/gui' directory, when compilation fails with missing headers (eg
QtWidgets).

I'll need to think whether I really want to upgrade (from 4.8.7) to 5.11, I
remember it (building from source) being a seriously lengthy affair in 2010 or
so.  in addition, I have not even found the source archive on the qt-project.org
website yet, only link(s) to online installers.  </sigh>


regards, jr.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.