POV-Ray : Newsgroups : povray.programming : qtpovray and debian : Re: qtpovray and debian Server Time
27 Sep 2022 19:20:26 EDT (-0400)
  Re: qtpovray and debian  
From: clipka
Date: 22 Jun 2018 14:56:32
Message: <5b2d4660$1@news.povray.org>
Am 22.06.2018 um 17:12 schrieb jr:

> g++ -c -pipe -O2 -w -fPIC -D_REENTRANT -DQT_DEPRECATED_WARNINGS
> -DOPENEXR_MISSING -DBUILD_ARCH="x86_64" -DTRY_OPTIMIZED_NOISE -DBUILD_X86
> -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_SHARED -I/usr/lib64/qt/mkspecs/linux-g++ -I.
> -I/usr/lib64/qt/include/QtCore -I/usr/lib64/qt/include -I../../source
> -I../../platform/unix -I../../platform/x86 -I../../unix/povconfig -I../../vfe
> -I. -o tmp/QP/povray/source/backend/bounding/boundingtask.o
> ...../../source/backend/bounding/boundingtask.cpp
> In file included from ../../source/backend/frame.h:57:0,
>                  from ../../source/backend/bounding/boundingtask.cpp:42:
> ...../../source/base/configbase.h:1048:6: error: #error "This version of POV-Ray
> requires C++11, which your compiler does not seem to support."
>      #error "This version of POV-Ray requires C++11, which your compiler does
> not seem to support."
>       ^

Presuming that you have g++ 4.8.1 or later at your disposal, you need to
smuggle a `-std=c++11` or `-std=gnu++11` into the g++ command line. The
CPPFLAGS environment variable might do the trick.

The setting is required for all g++ versions prior to 6.1.


> I know you're only concerned with Ubuntu, but thought you'd like to know.

From what I understand, Dick is only concerned with Debian, not Ubuntu ;)


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.