POV-Ray : Newsgroups : povray.macintosh : missing library? Server Time
16 Sep 2021 07:58:00 EDT (-0400)
  missing library? (Message 1 to 2 of 2)  
From: Anton Sherwood
Subject: missing library?
Date: 4 Feb 2007 05:24:15
Message: <45c5b44f$1@news.povray.org>
I wiped and reinstalled MacOS recently, and the first time I go to run 
Povray (Unix-style, not as a Mac-style app) I get this:

	dyld: Library not loaded: /usr/X11R6/lib/libXpm.4.dylib

I sure don't remember having to install that before.  I go to that 
directory and see that "libXpm.4.11.dylib" exists, so I make 
"libXpm.4.dylib" a link to it, and try again.

	dyld: Library not loaded: /usr/X11R6/lib/libSM.6.dylib

Sigh.  The nearest thing this time is libSM.a, and linking doesn't work.

Have I missed something obvious?

-- 
Anton Sherwood, http://www.ogre.nu/
"How'd ya like to climb this high *without* no mountain?" --Porky Pine


Post a reply to this message

From: Anton Sherwood
Subject: Re: missing library?
Date: 5 Feb 2007 23:45:26
Message: <45c807e6$1@news.povray.org>
Anton Sherwood wrote:
> I wiped and reinstalled MacOS recently, and the first time I go to run 
> Povray (Unix-style, not as a Mac-style app) I get this:
> 
>     dyld: Library not loaded: /usr/X11R6/lib/libXpm.4.dylib

	...

Well I downloaded the source again and recompiled, and now it's happy.

-- 
Anton Sherwood, http://www.ogre.nu/
"How'd ya like to climb this high *without* no mountain?" --Porky Pine


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.