POV-Ray : Newsgroups : povray.general : Survey: Compilers Used : Re: Survey: Compilers Used Server Time
20 Sep 2021 09:46:29 EDT (-0400)
  Re: Survey: Compilers Used  
From: Le Forgeron
Date: 20 Jun 2017 16:39:44
Message: <59498810@news.povray.org>
Le 20/06/2017 à 16:27, clipka a écrit :
> Hi folks,
> 
> I'd like to get some feedback on what compilers you are using to build
> your own POV-Ray binaries (if applicable).
> 
> More specifically, I'd like to know whether anyone is using something
> *OTHER* than one of the following:
> 
> - Microsoft Visual Studio 2015 or later.
> - Gnu Compiler Collection 4.8.1 or later.
> - Clang 3.3 or later.
> 
> So if you are using an older version of the above compilers, or an
> entirely different compiler, please let us know.
> 

3 Compilers in use here (64 bits, intel processor):
* Intel icpc 17.0.4 (from intel parallel studio XE 2017 update 4, for Linux)
* Gnu g++ 6.3.0 (from ubuntu 17.04)
* Clang 4.0.0 (from ubuntu) 17.04)


> 
> The ultimate purpose of this survey is to determine which C++11 features
> might be safe to use in the POV-Ray source code.
> 

Did you known there is C++14 and ...
Winter is coming... no, C++17 is coming!


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.