POV-Ray : Newsgroups : povray.bugreports : artifacts on lathe object Server Time
1 Dec 2021 05:07:35 EST (-0500)
  artifacts on lathe object (Message 11 to 15 of 15)  
<<< Previous 10 Messages Goto Initial 10 Messages
From: clipka
Subject: Re: artifacts on lathe object
Date: 11 Oct 2017 04:57:02
Message: <59dddcde@news.povray.org>
Am 09.10.2017 um 23:16 schrieb David Mandelberg:
> When I render the below scene, there are some spurious black artifacts near the
> center of the red vuvuzela. Without the translation and rotation, the artifacts
> go away. I'm using POV-Ray 3.7.0 on Ubuntu 16.04.

I wouldn't be surprised if these artefacts were related to a similar
issue with 3rd-order polynomials (e.g. bezier or cubic) in the sphere
sweep primitive.


Post a reply to this message

From: clipka
Subject: Re: artifacts on lathe object
Date: 11 Oct 2017 04:57:48
Message: <59dddd0c$1@news.povray.org>
Am 11.10.2017 um 05:00 schrieb omniverse:
> "omniverse" <omn### [at] charternet> wrote:
> Of course I notice after posting my last reply that simply adding keyword sturm
> to the sor bell fixes it completely, at least from what I can see from the
> example.
> 
> Unfortunate that the same can't be said for lathe, which doesn't seem affected
> by sturm at all.

It should be though, as it does pass the flag to the root solver.


Post a reply to this message

From: William F Pokorny
Subject: Re: artifacts on lathe object
Date: 16 Oct 2017 08:05:09
Message: <59e4a075$1@news.povray.org>
On 10/11/2017 04:57 AM, clipka wrote:
> Am 09.10.2017 um 23:16 schrieb David Mandelberg:
>> When I render the below scene, there are some spurious black artifacts near the
>> center of the red vuvuzela. Without the translation and rotation, the artifacts
>> go away. I'm using POV-Ray 3.7.0 on Ubuntu 16.04.
> 
> I wouldn't be surprised if these artefacts were related to a similar
> issue with 3rd-order polynomials (e.g. bezier or cubic) in the sphere
> sweep primitive.
> 

I too think this likely the case.

Christoph, do you want to update the sphere_sweep github issue :

https://github.com/POV-Ray/povray/issues/147

to include this lathe case?

Or, should we create a new github issue for it and reference #147 as 
likely related?

Bill P.


Post a reply to this message

From: clipka
Subject: Re: artifacts on lathe object
Date: 16 Oct 2017 10:05:01
Message: <web.59e4bc04d40b44f2160105a20@news.povray.org>
William F Pokorny <ano### [at] anonymousorg> wrote:
> On 10/11/2017 04:57 AM, clipka wrote:
> > Am 09.10.2017 um 23:16 schrieb David Mandelberg:
> >> When I render the below scene, there are some spurious black artifacts near the
> >> center of the red vuvuzela. Without the translation and rotation, the artifacts
> >> go away. I'm using POV-Ray 3.7.0 on Ubuntu 16.04.
> >
> > I wouldn't be surprised if these artefacts were related to a similar
> > issue with 3rd-order polynomials (e.g. bezier or cubic) in the sphere
> > sweep primitive.
> >
>
> I too think this likely the case.
>
> Christoph, do you want to update the sphere_sweep github issue :
>
> https://github.com/POV-Ray/povray/issues/147
>
> to include this lathe case?
>
> Or, should we create a new github issue for it and reference #147 as
> likely related?
>
> Bill P.

I think it would be cleaner to create a new issue. We don't know at this point
whether they are genuinely related -- and I'm pretty sure each needs its own
separate fix anyway.


Post a reply to this message

From: William F Pokorny
Subject: Re: artifacts on lathe object
Date: 17 Oct 2017 09:35:28
Message: <59e60720$1@news.povray.org>
On 10/16/2017 10:02 AM, clipka wrote:
> William F Pokorny <ano### [at] anonymousorg> wrote:
>...
> I think it would be cleaner to create a new issue. We don't know at this point
> whether they are genuinely related -- and I'm pretty sure each needs its own
> separate fix anyway.
> 
OK. See: https://github.com/POV-Ray/povray/issues/335


Post a reply to this message

<<< Previous 10 Messages Goto Initial 10 Messages

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.