POV-Ray : Newsgroups : povray.binaries.programming : yuqk tarballs for Unix/Linux - Ubuntu : yuqk tarballs for Unix/Linux - Ubuntu Server Time
14 Apr 2024 13:15:56 EDT (-0400)
  yuqk tarballs for Unix/Linux - Ubuntu  
From: kurtz le pirate
Date: 30 Mar 2024 06:52:42
Message: <6607eefa$1@news.povray.org>
Hello,

My VMWare has crashed and I've lost my vm :(
That's all right. I'm making another one.

So as not to have the same problems as the other times, I made a script
that checks the presence of the libraries and their versions.

If it helps...
--------------------------------------------------------------------------------
#!/bin/bash
clear
echo -e "\n\n--- Needed packages for povray yuqk\n"
NeededPackages=("libboost-dev" "libboost-date-time-dev"
"libboost-thread-dev" "zlib1g-dev" "libpng12-dev" "libjpeg8-dev"
"libtiff5-dev" "libopenexr-dev")

for p in ${NeededPackages[@]}; do
  dpkg -l $p >/dev/null 2>&1
  # is here ?
  if [ $? -ne 0 ]
    then
    echo -e ">> \"$p\" not installed or issue retrieving informations.\n"
  # need upgrade ?
  else
    NeedUpgrade=$(apt-get -s upgrade -u | egrep -c "^Conf $p |^Inst $p ")
    if [ $NeedUpgrade -gt 0 ]
    then
      echo -e ">> \"$p\" need an upgrade.\n"
    else
      echo -e ">> \"$p\" is up to date.\n"
    fi
  fi
done
echo -e "end...\n"
--------------------------------------------------------------------------------

ps: I'm an Ubuntu beginner, so please bear with me.


-- 
Kurtz le pirate
Compagnie de la Banquise


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.