POV-Ray : Newsgroups : povray.binaries.programming : ppm.cpp patch : ppm.cpp patch Server Time
24 Sep 2021 09:19:16 EDT (-0400)
  ppm.cpp patch  
From: PoD
Date: 25 Jan 2003 07:19:04
Message: <3e3280b8@news.povray.org>
As reported in p.g, POV-Ray 3.5 does not read PPM files properly.
The proper format is
P6
width height
max_value
data

The POV reader expects the max_value on the same line as the width and 
height.  If you don't want to patch POV-Ray, you can edit the PPM files 
to make them work in POV.

Here's a patch to fix it. I only spent a short time on this, so it's 
probably still broken but it loads the files that I've tried.

-- 
PoD.


Post a reply to this message


Attachments:
Download 'us-ascii' (2 KB)

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.