POV-Ray : Newsgroups : povray.binaries.images : Weird problem with transparent box : Re: Weird problem with transparent box Server Time
14 Aug 2022 15:41:07 EDT (-0400)
  Re: Weird problem with transparent box  
From: Chris R
Date: 23 Jun 2022 15:50:00
Message: <web.62b4c3863b7b32904ebf5035cc1b6e@news.povray.org>
"jr" <cre### [at] gmailcom> wrote:
> hi,
>
> "Chris R" <car### [at] comcastnet> wrote:
> > ...
> > I have created other scenes with completely transparent objects before and you
> > can't see the edges of them, and they don't reflect the scene around them.  I
> > just can't figure out why it's happening here.
>
> the same page also mentions the 'no_reflection' modifier (I was too lazy, in my
> head the 'no_{image,reflection,shadow}' modifiers "go together").  also, I
> wonder, perhaps give the box an explicitly non-reflective finish?
>
>
> regards, jr.

I took my main scene and eliminated everything but the transparent box, and even
added media to it and everything looked fine.  I added one scene element at a
time back and it was all fine until I added in the drip of water I had modeled
falling from the downspout.  As soon as I added that object back into the scene,
the transparent box with media became a reflective mirror instead!

The drip of water is modeled as a quartic.  It had a material to look like
water, (so transparent, ior 1.33, reflective, etc.).  When I changed the
material to just a simple gray pigment, the media box was no longer visible or
reflective, but the media also disappeared.

I wonder if there is some bug with quartics and textures?



-- Chris R.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.