POV-Ray : Newsgroups : povray.binaries.animations : media_attenuation of a light source -- animation tests : Re: media_attenuation of a light source -- animation tests Server Time
29 Nov 2022 19:29:24 EST (-0500)
  Re: media_attenuation of a light source -- animation tests  
From: William F Pokorny
Date: 16 Feb 2018 08:53:58
Message: <5a86e276$1@news.povray.org>
On 02/16/2018 01:49 AM, Kenneth wrote:
> This is a seven-part animation(!), to test media_attenuation of a light. This is
> the current POV-Ray behavior  (as of 3.7.1 beta 9, anyway; I haven't tested any
> 3.8 version.) See William Pokorny's separate thread about this topic...
> 
> 

Thanks for the detail and code. I'll come back to it, but I have other 
active threads too - under which I'm already buried! Your results are 
mostly in line with my tentative understanding and yep, the media run 
times are certainly a factor for me too on my little two core i3.

In trying to verify the media attenuation apart from the scattering I 
set up a simpler scene with with two renders - light in at top, light 
out at bottom. The attached image shows the difference at bottom. As I'd 
expect the media_attenuation is getting applied only in the band where 
the media is lit in the second and not to the background. In other words 
attenuation looks to me to be working - when it's on - at least to a 
first order.

Bill P.


Post a reply to this message


Attachments:
Download 'a_to_b.jpg' (46 KB)

Preview of image 'a_to_b.jpg'
a_to_b.jpg


 

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.