POV-Ray : Newsgroups : povray.beta-test : Parsing issue. Density and blend_mode, blend_gamma. : Re: Parsing issue. Density and blend_mode, blend_gamma. Server Time
21 Sep 2021 07:23:25 EDT (-0400)
  Re: Parsing issue. Density and blend_mode, blend_gamma.  
From: William F Pokorny
Date: 10 Feb 2021 14:20:48
Message: <60243210$1@news.povray.org>
On 2/10/21 2:50 AM, Thomas de Groot wrote:
> Op 09/02/2021 om 14:04 schreef William F Pokorny:
>> This fails to parse:
> 
> Says: "Must have at least one color in color map"
> 
> Strange.
> 
> Otherwise, this is a nice feature which I had not been aware of (or 
> forgot about; so many features in POV....)
> 
Yes & yes.

Chased this one for most of the day - and still not got it.

For reasons still a mystery, it appears the issue is with just 
'blend_gamma'. If you you specify only blend_mode everything is OK. You 
can change blend_mode with no issue.

For some reason the blend_gamma token is not getting picked/seen up when 
specified inside the density (or maybe media) block - that is the real 
error despite the message.

I usually define my maps stand alone (this not an issue for me basically 
in normal work flow) so I wondered how general the issue. Only tested 
color_maps defined within a pigment - and there blend_gamma works as 
expected.

Complicating things some, there is code for the color map parsing apart 
from all other map parsing due trying to maintain compatibility with 
some aspect of v1.0 of POV-Ray. I'll probably dump that special version 
in the povr branch - if I an work out how.

In any case, this is starting to look like some sort of deeper parser 
issue. At the moment I'm baffled.

Bill P.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.