POV-Ray : Newsgroups : povray.beta-test : Updated parser. Standard include warning noise. : Updated parser. Standard include warning noise. Server Time
23 Jun 2021 13:40:07 EDT (-0400)
  Updated parser. Standard include warning noise.  
From: William F Pokorny
Date: 7 Feb 2019 09:56:59
Message: <5c5c473b$1@news.povray.org>
Not sure the particular type of warning introduced with the new parser 
or just post v3.7. Also not sure what might be done to lesson the 
warning noise other than update the shipped includes all to version 3.8 
in the master branch.

Anyway, while running the updated parser code (my branches merged off 
master commit 054e75c), noticing warning messages where scenes (and the 
default statement) are at version 3.8. Warnings of the form:

File
'/dev/shm/tmpDir/tmpUser/MyP380/share/povray-3.8/include/colors.inc' 
line 13:
Parse Warning: Scene language version changed after a 'default' 
statement. The changes in defaults normally associated with the language 
version change are not applied.

Any scene with something like:

//---
#version 3.8;
global_settings{ assumed_gamma 1.0 ... }
#default { ... }

...
#include "colors.inc"
...
//---

where the include drops back to an earlier version triggers them and, 
depending on scene construction, makes for quite a bit of useless 
warning noise.

Bill P.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.