POV-Ray : Newsgroups : povray.beta-test : POV-Ray v3.8.0-alpha.10011104 : Re: POV-Ray v3.8.0-alpha.10011104 Server Time
25 Sep 2021 05:48:12 EDT (-0400)
  Re: POV-Ray v3.8.0-alpha.10011104  
From: clipka
Date: 13 Jan 2019 14:46:22
Message: <5c3b958e$1@news.povray.org>
Am 13.01.2019 um 18:23 schrieb jr:
> hi,
> 
> clipka <ano### [at] anonymousorg> wrote:
>> Am 13.01.2019 um 17:11 schrieb jr:
>>> I've tried with two scenes, one crashes, the other does not.  the only
>>> difference, afaict, is that the first uses array syntax in both declaration and
>>> in one of the function components, while the second has no array stuff.
>>
>> Then the recommended workaround probably applies to your system and, by
>> extension, presumably Unix systems in general.
> 
> ok.  do you have a 'wget'able url for that file, please?

I have no idea what a "'wget'able" URL is, but maybe this one qualifies:

https://raw.githubusercontent.com/POV-Ray/povray/master/source/parser/parser_functions_utilities.cpp


> btw, the alpha (also) crashes when there's an "old-style" text primitive, ie
> without cmap {}, irrespective of charset present in global_settings.  does the
> above workaround fix that too?

I thought you were confirming that v3.8.0-alpha.10011104 fixed your 
issue? Please clarify, and double-check the version you're running.

Those `text` primitive crashes you were observing are totally unrelated 
to the user-defined function crashes.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.