POV-Ray : Newsgroups : povray.beta-test : Front end cannot process .ini files : Front end cannot process .ini files Server Time
23 Jun 2021 14:53:04 EDT (-0400)
  Front end cannot process .ini files  
From: Cousin Ricky
Date: 4 Nov 2018 17:41:47
Message: <5bdf75ab$1@news.povray.org>
POV-Ray 3.8 cannot process .ini files in my library path; I have to 
provide the path to the .ini file in order to get a successful render. 
For example:

My povray.ini contains:

---------- [BEGIN FILE EXCERPT] ----------
Library_Path="/usr/local/share/povray-3.8"
Library_Path="/usr/local/share/povray-3.8/ini"
Library_Path="/usr/local/share/povray-3.8/include"
Library_Path="/home/ricky/Documents/POV-Ray/include"
Library_Path="/home/ricky/Documents/POV-Ray/include-others"
Library_Path="/home/ricky/Documents/POV-Ray/Object_Collection"
Library_Path="/home/ricky/Documents/POV-Ray/LightsysIV"
Library_Path="/usr/share/fonts/truetype"
Library_Path="/home/ricky/.fonts"
----------- [END FILE EXCERPT] -----------

These paths are confirmed in the message window of a successful render.

Directory /home/ricky/Documents/POV-Ray/include, which is in the library 
path, contains the file:

   jpeg.ini

Directory /home/ricky/Documents/POV-Ray/plane contains the file:

   myscene.pov

 From /home/ricky/Documents/POV-Ray/plane I run the command:

   povray-3.8 myscene.pov jpeg

("povray-3.8" is what I renamed the 3.8 executable, as I still default 
to POV-Ray 3.7.0.)

The command fails with the message:

---------- [BEGIN ERROR MESSAGE] ----------

Problem with option setting
povray-3.8 myscene.pov jpeg
Failed to parse command-line option
----------- [END ERROR MESSAGE] -----------

This command renders without errors:

   povray-3.8 myscene.pov ../include/jpeg

This problem has existed since the POV-Ray 3.7.1 betas, and is present 
in the latest UberPOV.  Previous versions of POV-Ray do not have this 
problem.  (Earlier, I reported a failure to process certain .ini files 
from within their own directory; that problem no longer occurs.)

There is no problem locating #include files from within a scene file.

POV-Ray version: 3.8.0-alpha.9893777.unofficial (g++ 7 @ 
x86_64-pc-linux-gnu)
OS: openSUSE Leap 15.0 (GNU/Linux)


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.