POV-Ray : Newsgroups : irtc.animations : Re: cmpeg not being nice to me Server Time
22 May 2024 22:20:04 EDT (-0400)
  Re: cmpeg not being nice to me (Message 1 to 4 of 4)  
From: Nieminen Juha
Subject: Re: cmpeg not being nice to me
Date: 31 Jan 2000 04:07:27
Message: <389550cf@news.povray.org>
Serge <sgl### [at] hotmailcom> wrote:
: 2 - It categorically rejects working if I use the framelist parameter
: which requires 0's to be padded eg:   cmpeg -t1 ipb.ctl file%02d.tga
: movie.mpg won't work, but would if I specify a file containing all the
: image filenames. Even with cut and paste, it's still a lot of manual
: typing to create the list :(

  Graphical GUIs like Windows have taught bad habits to people.
  The command line interpreter (usually command.com in windows) is a very
handy tool, my friend. I warmly suggest you to learn how to use it.
  I use cmpeg a lot and also have the problem of the framelist parameter not
working, so I always use the filename listing file method. The file is very
easyly created with a command like:

dir /b /on *.tga > frames.lst

-- 
main(i,_){for(_?--i,main(i+2,"FhhQHFIJD|FQTITFN]zRFHhhTBFHhhTBFysdB"[i]
):5;i&&_>1;printf("%s",_-70?_&1?"[]":" ":(_=0,"\n")),_/=2);} /*- Warp -*/


Post a reply to this message

From: ingo
Subject: Re: cmpeg not being nice to me
Date: 31 Jan 2000 09:16:54
Message: <8ECC9C74Bseed7@204.213.191.228>
Serge wrote:

>2 - It categorically rejects working if I use the framelist parameter
>which requires 0's to be padded eg:   cmpeg -t1 ipb.ctl file%02d.tga
>

Your first frame has to be frame 0 and not frame 1, then it works ok.
Ingo

-- 
Photography: http://members.home.nl/ingoogni/
Pov-Ray    : http://members.home.nl/seed7/


Post a reply to this message

From: John VanSickle
Subject: Re: cmpeg not being nice to me
Date: 31 Jan 2000 20:50:44
Message: <38963DF7.BD57DEC3@erols.com>
Serge wrote:
> 
> I just started using cmpeg a few days ago and test compiled a few
> animations.
> 
> 2 - It categorically rejects working if I use the framelist parameter
> which requires 0's to be padded eg:   cmpeg -t1 ipb.ctl file%02d.tga
> movie.mpg won't work, but would if I specify a file containing all the
> image filenames. Even with cut and paste, it's still a lot of manual
> typing to create the list :(
> 
> What, if anything, can I do about this?

In addition to the advice ingo gave, you also need to make sure that
the frames are consecutively numbered, or else CMPEG will stop at the
first discontinuity, if you use the pattern matching option.

Regards,
John
-- 
ICQ: 46085459


Post a reply to this message

From: Sander
Subject: Re: cmpeg not being nice to me
Date: 17 Feb 2000 03:39:08
Message: <38abb3ac@news.povray.org>
If you use W95/98 or NT4 and haven't had any success yet, you could try my
Windows front end to CMPEG, to be found at http://stols.net .

--
Regards,
Sander


Serge <sgl### [at] hotmailcom> schreef in berichtnieuws
3895305F.A3F614CD@hotmail.com...
> I just started using cmpeg a few days ago and test compiled a few
> animations.
>
> 1 - The quality is good - far better than what I was getting with
> creating avi's then using avi2mpg to convert
>
> 2 - It categorically rejects working if I use the framelist parameter
> which requires 0's to be padded eg:   cmpeg -t1 ipb.ctl file%02d.tga
> movie.mpg won't work, but would if I specify a file containing all the
> image filenames. Even with cut and paste, it's still a lot of manual
> typing to create the list :(
>
> What, if anything, can I do about this?
>


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.