POV-Ray : Newsgroups : povray.unix : Compiling POV-Ray 3.7, second attempt Server Time: 14 Dec 2018 09:35:47 GMT
  Compiling POV-Ray 3.7, second attempt (Message 1 to 10 of 26)  
Goto Latest 10 Messages Next 10 Messages >>>
From: "Jörg \"Yadgar\" Bleimann"
Subject: Compiling POV-Ray 3.7, second attempt
Date: 3 Jul 2015 23:20:19
Message: <559718b3$1@news.povray.org>
Hi(gh)!

After replacing my entire previous Linux installation by Debian 7.8 
"wheezy", I once more tried to compile POV-Ray 3.7... now, all 
additional packages recommended in unix/README.md were installed without 
any errors. When I started the prebuild.sh script, all worked well - 
except for one final error message:

config.status: error: cannot find input file: `Makefile.in'

I thought that make was not installed yet, so I did this and afterward 
typed "make" (like read under "Generating configure and building the 
code" in README.md) - but this also just resulted in an error message:

make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. 
  Schluss.
(which is in English:
make: *** No targets stated and no »make« directive file found. Ending.)

How do I get rid of the config.status error?

See you in Khyberspace!

Yadgar


Post a reply to this message

From: clipka
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 4 Jul 2015 03:59:55
Message: <55975a3b$1@news.povray.org>
Am 04.07.2015 um 01:20 schrieb "Jörg \"Yadgar\" Bleimann":
> Hi(gh)!
>
> After replacing my entire previous Linux installation by Debian 7.8
> "wheezy", I once more tried to compile POV-Ray 3.7... now, all
> additional packages recommended in unix/README.md were installed without
> any errors. When I started the prebuild.sh script, all worked well -
> except for one final error message:
>
> config.status: error: cannot find input file: `Makefile.in'

Quite obviously, all worked /not/ well. You might want to double-check 
the output messages - I guess they do report /some/ error or warning. At 
any rate you don't seem to be reporting the exact symptoms, as 
"config.status" doesn't come into play until the "./configure" step.

What version of POV-Ray 3.7 are you trying to build?

3.7.0 stable release, for instance, is known to not configure properly 
with new versions of automake, causing secondary error messages similar 
to the one you're reporting.


Post a reply to this message

From: Le Forgeron
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 4 Jul 2015 10:50:41
Message: <5597ba81$1@news.povray.org>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Le 04/07/2015 05:59, clipka a écrit :
> Am 04.07.2015 um 01:20 schrieb "Jörg \"Yadgar\" Bleimann":
>> Hi(gh)!
>> 
>> After replacing my entire previous Linux installation by Debian
>> 7.8 "wheezy", I once more tried to compile POV-Ray 3.7... now,
>> all additional packages recommended in unix/README.md were
>> installed without any errors. When I started the prebuild.sh
>> script, all worked well - except for one final error message:
>> 
>> config.status: error: cannot find input file: `Makefile.in'
> 
> Quite obviously, all worked /not/ well. You might want to
> double-check the output messages - I guess they do report /some/
> error or warning. At any rate you don't seem to be reporting the
> exact symptoms, as "config.status" doesn't come into play until the
> "./configure" step.
> 
> What version of POV-Ray 3.7 are you trying to build?
> 
> 3.7.0 stable release, for instance, is known to not configure
> properly with new versions of automake, causing secondary error
> messages similar to the one you're reporting.
> 

Well spotted. To build 3.7.0 stable, which is likely due to the
message about "Makefile.in", a workaround on modern system is:

1. in unix directory: ./prebuild.sh
2. in root directory: automake --add-missing
3. in unix directory: ./prebuild.sh

then continue as usual.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iJwEAQEIAAYFAlWXuoAACgkQhKAm8mTpkW3VCwP/SNTKj7MUPnJCg7nf22MUW8dv
Q2Gqdh5eXCgFTWJ36HbpfnJVxMCnN80dwv7e7rCIpwMtlHiNYsFAvuqUbbx6NPfF
QtqeJIKsyAQvbWrbdSHJKJ3K65F0AYFCche9XGN1+fLloONXHJyTX7bMypv2Ztkm
x/ojaMbJvJsdSXTu2P4=
=MQ2E
-----END PGP SIGNATURE-----


Post a reply to this message

From: "Jörg \"Yadgar\" Bleimann"
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 4 Jul 2015 22:14:26
Message: <55985ac2@news.povray.org>
Hi(gh)!

On 04.07.2015 05:59, clipka wrote:

> Quite obviously, all worked /not/ well. You might want to double-check
> the output messages - I guess they do report /some/ error or warning. At
> any rate you don't seem to be reporting the exact symptoms, as
> "config.status" doesn't come into play until the "./configure" step.

O.k., here is the output of prebuild.sh:

root@debian:/media/Raytracing/povray-3.7-stable/unix# ./prebuild.sh
Detected autoconf 2.69
Detected automake 1.11.6
Create ../AUTHORS
Create ../ChangeLog
Create ../configure.ac
Create ../COPYING
Create ../NEWS
Create ../README
Create ../VERSION
Create ../povray.1
Create ../povray.conf
Create ../scripts/
Create ../ini/
Create ../include/
Create ../scenes/
Create ../INSTALL
Create ../icons/file_inc_classic_16.png
Create ../icons/file_inc_crystal_16.png
Create ../icons/file_inc_slick_64.png
Create ../icons/file_inc_slick_32.png
Create ../icons/file_pov_classic_64.png
Create ../icons/file_inc_crystal_64.png
Create ../icons/file_inc_classic_48.png
Create ../icons/file_pov_classic_16.png
Create ../icons/file_inc_slick_16.png
Create ../icons/file_pov_crystal_64.png
Create ../icons/povray_16.png
Create ../icons/file_inc_classic_32.png
Create ../icons/povray_48.png
Create ../icons/file_inc_classic_64.png
Create ../icons/file_pov_classic_48.png
Create ../icons/file_pov_slick_48.png
Create ../icons/file_pov_crystal_16.png
Create ../icons/povray_32.png
Create ../icons/file_pov_slick_32.png
Create ../icons/file_inc_slick_48.png
Create ../icons/file_pov_crystal_32.png
Create ../icons/file_inc_crystal_48.png
Create ../icons/file_pov_slick_64.png
Create ../icons/file_inc_crystal_32.png
Create ../icons/file_pov_crystal_48.png
Create ../icons/file_pov_slick_16.png
Create ../icons/povray_64.png
Create ../icons/file_pov_classic_32.png
Create ../doc/html
Create ./Makefile.am
Create ../kde_install.sh
Create ../povray.ini.in
Create ../Makefile.am
Create ../bootstrap
Create ../source/Makefile.am
Create ../vfe/Makefile.am
Run ../bootstrap
+ rm -f config.log config.status
+ aclocal -I .
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call 
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ autoheader --warnings=all
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call 
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ automake --warnings=all
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call 
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ autoconf --warnings=all
configure.ac:295: warning: The macro `AC_LANG_SAVE' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/lang.m4:125: AC_LANG_SAVE is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_LANG_C' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/c.m4:72: AC_LANG_C is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_TRY_LINK' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/general.m4:2687: AC_TRY_LINK is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_LANG_RESTORE' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/lang.m4:134: AC_LANG_RESTORE is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call 
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ cat ./configure
+ sed -e s,configure.gnu  --help=recursive,& --srcdir=$ac_srcdir,g -e 
s,\(cd \)\($ac_\)\(pop\)*\(dir\),\1"\2\3\4",g -e 
s,$am_aux_dir/missing,\\"$am_aux_dir\\"/missing,g
+ mv -f ./configure.tmp ./configure
+ chmod +x ./configure
+ rm -f -r ./autom4te.cache


> What version of POV-Ray 3.7 are you trying to build?

3.7.0 stable, as documented here: 
https://github.com/POV-Ray/povray/tree/3.7-stable

See you in Khyberspace!

Yadgar


Post a reply to this message

From: "Jörg \"Yadgar\" Bleimann"
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 4 Jul 2015 22:17:23
Message: <55985b73$1@news.povray.org>
Hi(gh)!

On 04.07.2015 12:50, Le_Forgeron wrote:

> Well spotted. To build 3.7.0 stable, which is likely due to the
> message about "Makefile.in", a workaround on modern system is:
>
> 1. in unix directory: ./prebuild.sh
> 2. in root directory: automake --add-missing

Does not work with me... I got:

automake: `configure.ac' or `configure.in' is required

Perhaps my system is not modern enough...

See you in Khyberspace!

Yadgar


Post a reply to this message

From: clipka
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 5 Jul 2015 00:30:46
Message: <55987ab6@news.povray.org>
Am 05.07.2015 um 00:14 schrieb "Jörg \"Yadgar\" Bleimann":

> configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
> detected in body

That's pretty unusual AFAIK, and might be related to the problems.


Post a reply to this message

From: "Jörg \"Yadgar\" Bleimann"
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 7 Jul 2015 17:07:19
Message: <559c0747$1@news.povray.org>
Hi(gh)!

On 05.07.2015 02:30, clipka wrote:
> Am 05.07.2015 um 00:14 schrieb "Jörg \"Yadgar\" Bleimann":
>
>> configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
>> detected in body
>
> That's pretty unusual AFAIK, and might be related to the problems.

And now? I have no clue about all that... will I ever be able to compile 
POV-Ray 3.7 on my own?

See you in Khyberspace!

Yadgar


Post a reply to this message

From: clipka
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 8 Jul 2015 01:41:22
Message: <559c7fc2$1@news.povray.org>
Am 07.07.2015 um 19:07 schrieb "Jörg \"Yadgar\" Bleimann":
> Hi(gh)!
>
> On 05.07.2015 02:30, clipka wrote:
>> Am 05.07.2015 um 00:14 schrieb "Jörg \"Yadgar\" Bleimann":
>>
>>> configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
>>> detected in body
>>
>> That's pretty unusual AFAIK, and might be related to the problems.
>
> And now? I have no clue about all that... will I ever be able to compile
> POV-Ray 3.7 on my own?

Don't know - my Linux expertise ends here. I'm a Windows jockey after 
all, and I have no Debian installation at my disposal to dig deeper into 
the issue.


Post a reply to this message

From: Le Forgeron
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 8 Jul 2015 06:09:30
Message: <559cbe9a$1@news.povray.org>
Le 05/07/2015 00:17, "Jörg \"Yadgar\" Bleimann" a écrit :
> Hi(gh)!
>
> On 04.07.2015 12:50, Le_Forgeron wrote:
>
>> Well spotted. To build 3.7.0 stable, which is likely due to the
>> message about "Makefile.in", a workaround on modern system is:
>>
>> 1. in unix directory: ./prebuild.sh
>> 2. in root directory: automake --add-missing
>
> Does not work with me... I got:
>
> automake: `configure.ac' or `configure.in' is required
>
> Perhaps my system is not modern enough...

you ran it as a sequence, right ?
And when stating "root" directory, I meant the root of the source tree 
of povray ( so, it's the "." of "./unix", not the "/" )


Post a reply to this message

From: "Jörg \"Yadgar\" Bleimann"
Subject: Re: Compiling POV-Ray 3.7, second attempt
Date: 8 Jul 2015 10:54:55
Message: <559d017f$1@news.povray.org>
Hi(gh)!

On 08.07.2015 08:07, Le_Forgeron wrote:

> you ran it as a sequence, right ?
> And when stating "root" directory, I meant the root of the source tree
> of povray ( so, it's the "." of "./unix", not the "/" )

O.k., second try...

Now it generally worked, but with automake, I got one warning:

configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call 
detected in body

See you in Khyberspace!

Yadgar


Post a reply to this message

Goto Latest 10 Messages Next 10 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.