POV-Ray : Newsgroups : povray.beta-test : beta 30 Pause broken when animation rendering Server Time: 27 Jun 2019 04:24:22 GMT
  beta 30 Pause broken when animation rendering (Message 1 to 5 of 5)  
From: Bob Hughes
Subject: beta 30 Pause broken when animation rendering
Date: 15 Jan 2009 01:53:36
Message: <496e9720$1@news.povray.org>
This seemed a familiar problem from the past but I didn't find any reference 
to it here, except for changes.txt stating beta 4 had improved cancel/pause 
(possibly something related in beta 20 too?).

There could be some difference between parsing and rendering when Pause is 
used, but I experienced both cause POV to stop without any error messages. 
Must exit and wait for Windows to ask what to do.

Not getting the same when non-animations are Paused, so that seems OK.

And, strange coincidence or not, I was going to check this in 
3.6.1c.icl8.w32 and it won't even start animations. I tried one as simple as 
this to find out if it always happens:

//cmd:-w320 -h240 -ki0 -kf1 -kfi1 -kff50

sphere { <1-clock,0,3>, 1 pigment { rgb 1 } finish {ambient 1}}

Haven't done this using my other computer with XP so this was in Vista. 
Fairly certain this wasn't happening in times past.
AMD Turion X2 dual core processor, if that matters.

Bob


Post a reply to this message

From: Bridgeofstraws
Subject: Re: beta 30 Pause broken when animation rendering
Date: 15 Jan 2009 03:35:00
Message: <web.496eae55227a5eedc5ec9c90@news.povray.org>
"Bob Hughes" <omniverse charter net> wrote:
> This seemed a familiar problem from the past but I didn't find any reference
> to it here, except for changes.txt stating beta 4 had improved cancel/pause
> (possibly something related in beta 20 too?).
>
> There could be some difference between parsing and rendering when Pause is
> used, but I experienced both cause POV to stop without any error messages.
> Must exit and wait for Windows to ask what to do.
>
> Not getting the same when non-animations are Paused, so that seems OK.
>

I'm a afraid i can't help here.

> And, strange coincidence or not, I was going to check this in
> 3.6.1c.icl8.w32 and it won't even start animations. I tried one as simple as
> this to find out if it always happens:
>
> //cmd:-w320 -h240 -ki0 -kf1 -kfi1 -kff50
>
> sphere { <1-clock,0,3>, 1 pigment { rgb 1 } finish {ambient 1}}
>
> Haven't done this using my other computer with XP so this was in Vista.
> Fairly certain this wasn't happening in times past.
> AMD Turion X2 dual core processor, if that matters.
>
> Bob

However, I do know how to solve this! =)  All you have to do is go to the
properties of the "pvengine.exe" and under the compatibility tab you must
checkmark "Disable visual themes".  This hopefully helps.  Let me know if it
doesn't and maybe I can help further.  (I'm becoming fairly proficient with
fixing Vista compatability because of all the practice I get from using so many
"apparently" incompatable programs)

Bridgeofstraws


Post a reply to this message

From: SafePit
Subject: Re: beta 30 Pause broken when animation rendering
Date: 15 Jan 2009 05:10:01
Message: <web.496ec3ff227a5eedf434b86a0@news.povray.org>
"Bridgeofstraws" <bri### [at] inboxcom> wrote:
> However, I do know how to solve this! =)  All you have to do is go to the
> properties of the "pvengine.exe" and under the compatibility tab you must
> checkmark "Disable visual themes".  This hopefully helps.  Let me know if it
> doesn't and maybe I can help further.  (I'm becoming fairly proficient with
> fixing Vista compatability because of all the practice I get from using so many
> "apparently" incompatable programs)

Oddly, I remember doing this for Beta 29 but not for Beta 30.  I just check and
the compatibility option isn't check yet I'm no longer freezing with the +KFF
option like I did before.  I wonder if Vista remembered the old setting?


Post a reply to this message

From: Bob Hughes
Subject: Re: beta 30 Pause broken when animation rendering
Date: 15 Jan 2009 07:32:40
Message: <496ee698$1@news.povray.org>
"SafePit" <ste### [at] reids4funcom> wrote in message 
news:web.496ec3ff227a5eedf434b86a0@news.povray.org...
> "Bridgeofstraws" <bri### [at] inboxcom> wrote:
>> However, I do know how to solve this! =)  All you have to do is go to the
>> properties of the "pvengine.exe" and under the compatibility tab you must
>> checkmark "Disable visual themes".  This hopefully helps.  Let me know if 
>> it
>> doesn't and maybe I can help further.  (I'm becoming fairly proficient 
>> with
>> fixing Vista compatability because of all the practice I get from using 
>> so many
>> "apparently" incompatable programs)
>
> Oddly, I remember doing this for Beta 29 but not for Beta 30.  I just 
> check and
> the compatibility option isn't check yet I'm no longer freezing with the 
> +KFF
> option like I did before.  I wonder if Vista remembered the old setting?


I wouldn't think so, not since you must uninstall before doing a 
reinstall... but I sure don't know about all that for sure.

I recall that trick to disable themes for whatever reason (been so long 
ago!) but hadn't thought to try it. Doing so now only managed to make it 
possible to Stop the render and close the program normally, which I guess 
means something. No change about the Pause locking up permanently.
I noticed the timer and pixel count continues until stopped, and the menu 
bar blinks very slowly.
Compatibility changed to XP (SP2) and disabled themes only makes for a 
different appearance of the toolbar, unfortunately not how the Pause works 
so that won't help me. Will be a curious thing if it happens with mine and 
not other people.

Thanks for the suggestion nonetheless.

Bob


Post a reply to this message

From: Chris Cason
Subject: Re: beta 30 Pause broken when animation rendering
Date: 15 Feb 2009 12:03:48
Message: <499804a4@news.povray.org>
Thanks for pointing this out: I've been able to replicate it. I'll design a
more robust system of handling all these buttons for a later beta (not 31).

-- Chris


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.