POV-Ray : Newsgroups : povray.unofficial.patches : UberPOV v1.37.1.0-beta.9 released : Re: UberPOV v1.37.1.0-beta.9 released Server Time
17 Aug 2022 07:33:17 EDT (-0400)
  Re: UberPOV v1.37.1.0-beta.9 released  
From: clipka
Date: 31 Jan 2015 22:10:57
Message: <54cd9941$1@news.povray.org>
Am 01.02.2015 um 02:49 schrieb James Holsenback:

>> and noticed the checking whether g++ accepts yada-yada shows up for the
>> beta9 configure ... is that a clue?
>
> Oh ... and the Compiler flags shows -Wno-non-template-friend for b9 as well

Nope (presuming with "yada-yada" you mean "-Wno-non-template-friend"); 
this is just the suppression of an unwarranted warning from g++. 
Effectively, what this is all about is that there was a quirk in older 
g++ versions violating the C++ specs, and now by default they issue a 
warning just in case your code was relying on g++'s old behaviour.

I'll have a closer look at it. It's certainly not something affecting 
the Windows build.


Post a reply to this message

Copyright 2003-2021 Persistence of Vision Raytracer Pty. Ltd.