POV-Ray : Newsgroups : povray.windows : Benchmark bug on single core with Hyperthreading Server Time: 18 Jun 2019 04:55:57 GMT
  Benchmark bug on single core with Hyperthreading (Message 1 to 7 of 7)  
From: LucasGrijander
Subject: Benchmark bug on single core with Hyperthreading
Date: 7 Apr 2012 15:25:00
Message: <web.4f805c09748e0b37c71271e90@news.povray.org>
Hello,

   Pov-ray seems to believe that the atom Z520 (single core with HT), is a
single thread CPU and the "All CPU's benchmark" menuitem is missing, so only the
single thread benchmark can be run and the cpu usage is 50%.

   It seems to be a misinterpretation between "NumberOfCPUs" and "ThreadCount"
on pvengine.cpp.

Regards.


Post a reply to this message

From: LucasGrijander
Subject: Re: Benchmark bug on single core with Hyperthreading
Date: 8 Apr 2012 18:00:00
Message: <web.4f81d1d883fc5c7fc71271e90@news.povray.org>
It also fails on a dual Xeon E5645 with HT, only 50% of total CPU power is used,
is like HyperThreading is ignored.


Post a reply to this message

From: LucasGrijander
Subject: Re: Benchmark bug on single core with Hyperthreading
Date: 8 Apr 2012 18:05:01
Message: <web.4f81d30883fc5c7fc71271e90@news.povray.org>
more details on the dual Xeon 6-core, total 24 threads on the system:

- Normal rendering is working ok, 100% cpu usage.
- Benchmark:
    - pvengine.exe -> uses 50% of total cpu power.
    - pvengine-sse2.exe -> uses 50% of total cpu power.
    - pvengine64.exe -> uses 100% of cpu, this seems the only exe that works ok
with the benchmark.


Post a reply to this message

From: LucasGrijander
Subject: Re: Benchmark bug on single core with Hyperthreading
Date: 28 Jun 2012 15:35:00
Message: <web.4fec796083fc5c7fd389879d0@news.povray.org>
The proposed fix is in line 1886 of pvengine.cpp:

replace this line:
    threadCount = benchmark_multithread ? NumberOfCPUs : 1 ;

with this other:
    threadCount = benchmark_multithread ? ThreadCount : 1 ;


Post a reply to this message

From: LucasGrijander
Subject: Re: Benchmark bug on single core with Hyperthreading
Date: 28 Jun 2012 16:35:00
Message: <web.4fec86be83fc5c7fd389879d0@news.povray.org>
Also other line to modify is line 5906 of pvengine.cpp:

Change this:
  if (NumberOfCPUs == 1)

with this:
  if (ThreadCount == 1)


Post a reply to this message

From: LucasGrijander
Subject: Re: Benchmark bug on single core with Hyperthreading
Date: 7 Jul 2012 00:05:00
Message: <web.4ff77bff83fc5c7f9518ac580@news.povray.org>
The bug is partially fixed in RC6, in the dual xeon 12c/24t it runs at 100% cpu
usage, but with single-core hyperthreaded processors, like single core atom,
pentium 4, the option of "All CPUs" is not present, this should fix it:

At line 5906 of pvengine.cpp:

 Change this:
   if (NumberOfCPUs == 1)

 with this:
   if (ThreadCount == 1)


Post a reply to this message

From: Chris Cason
Subject: Re: Benchmark bug on single core with Hyperthreading
Date: 17 Jul 2012 22:57:55
Message: <5005edf3$1@news.povray.org>
Thanks for this information, I'll look into it and fix whatever is needed.

-- Chris


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.