POV-Ray : Newsgroups : povray.windows : compile povwin-src-3.7 question Server Time: 20 Aug 2014 10:41:46 GMT
  compile povwin-src-3.7 question (Message 1 to 4 of 4)  
From: tltsai
Subject: compile povwin-src-3.7 question
Date: 23 Nov 2010 08:40:00
Message: <web.4ceb7d5b7e0e98565d1d9d430@news.povray.org>
Hello,

I used visual studio 2005 to compile "povray.sln" in povwin-src-3.7.
I followed ReadMe , but when I executed pvengined.exe in
povwin-src-3.7\windows\vs8\bin32, it show message

==
This pre-releaseversion of POV-Ray for Windows has expired. We recommend you
obtain a new version,

if one is available,form our website,http://www.povray.org/beta/.
If however you wish to continue using this version,you may do so bu pressing the
EXTEND button,which will re-enable the program for an additional week,at which
time,you will be asked this question again.

If you choose to continue use,please be aware that newer versions that are made
available may fix bugs,add features,or render faster. You are strongly advised
to use newer versions when they become available.
==

But when I pressed the Extend button,it show another message

==
"This pre-release version of POV-RAY for Windows expired on 31 Dec 2010."
==

Can you suggest what should I do,so that I can compile
povwin-src-3.7\windows\vs8\povray.sln?

Additional,in Readme,He says:
"Set 'povwin' as the start-up project if it is not already selected."
But I can't find 'povwin' project.
so what project I should set it a startup projrct.


                                  tltsai


Post a reply to this message

From: Christian Froeschlin
Subject: Re: compile povwin-src-3.7 question
Date: 23 Nov 2010 21:33:14
Message: <4cec331a$1@news.povray.org>
> ==
> "This pre-release version of POV-RAY for Windows expired on 31 Dec 2010."
> ==

Are you using the most up-to-date sources for beta 39?
An earlier version (38?) had a problem of testing for Juli
2009 but showing Dec 2010 in the message box.

Otherwise: Is your system clock set correctly?

> But I can't find 'povwin' project.
> so what project I should set it a startup projrct.

When you open the solution file it should show multiple
projects in the solution explorer.


Post a reply to this message

From: tltsai
Subject: Re: compile povwin-src-3.7 question
Date: 24 Nov 2010 04:25:01
Message: <web.4cec9319107126785d1d9d430@news.povray.org>
Christian Froeschlin <chrfr [at] chrfrde> wrote:

> Are you using the most up-to-date sources for beta 39?
> An earlier version (38?) had a problem of testing for Juli
> 2009 but showing Dec 2010 in the message box.

Does source code for beta 39 release?
I don't see download link on http://www.povray.org/beta/

>
> Otherwise: Is your system clock set correctly?
>

yes


Post a reply to this message

From: Christian Froeschlin
Subject: Re: compile povwin-src-3.7 question
Date: 25 Nov 2010 00:12:42
Message: <4ceda9fa$1@news.povray.org>
tltsai wrote:

> Does source code for beta 39 release?
> I don't see download link on http://www.povray.org/beta/

sorry for misleading you, didn't check the latest
available sources. As there was a problem in an earlier
release it is possible the problem is still in the sources
as they are not yet for beta 39. You can circumvent the
problem by adapting the lines

#define EXPIRE_AT       (1272664800 + DAYS(92))
#define HARD_EXPIRY     (1293832800)

in source/backend/povray.h to a later date (in seconds).

It's not supposed to give you a hard expiry until 2011.
I suspect the problem are the lines

   if (_time32 (NULL) > EXPIRE_AT)
   {
     MessageBox (NULL, "This pre-release version of POV-Ray for Windows 
expired on 31 Dec 2010.", "Pre-release expired", MB_OK | MB_ICONSTOP) ;
     exit (1) ;
   }

in pvengine.cpp, which look a bit like a copy and paste
leftover from the HARD_EXPIRY test.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.