POV-Ray : Newsgroups : povray.unofficial.patches : Compiling UberPOV on MacOSX : Compiling UberPOV on MacOSX Server Time
23 Feb 2024 19:00:48 EST (-0500)
  Compiling UberPOV on MacOSX  
From: Bill Pragnell
Date: 2 Dec 2013 14:50:01
Message: <web.529ce3306d020212409e7c7f0@news.povray.org>
Since OSX is a unix, I would have thought compiling UberPOV by following the
unix instructions would be possible. However, I have had some problems I can't
quite get my head around, so some insights or help would be appreciated.

When running the prebuild script, I get lots of warnings about a subdir-objects
option, some warnings about using an AM_PROG_AR macro in configure.ac, some
warnings about obsolete macros, and an error from sed saying Makefile.in can't
be found. I can post the full text if necessary.

I looked in the UberPOV root, and the prebuild appeared to have done something,
so I tried to run configure anyway. This bailed when checking the available
libraries with 'cannot link with the boost thread library'.

Has the prebuild failed, or are these warnings expected?

I have boost 1.54 installed (via macports, if it's important), and the
libboost-thread stuff is definitely present - configure reports this to be so,
but fails when checking if the library is usable. If the prebuild is not at
fault, what might be amiss?

Bill


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.