POV-Ray : Newsgroups : povray.unofficial.patches : Compiling UberPOV on MacOSX : Re: Compiling UberPOV on MacOSX Server Time
23 Feb 2024 15:41:52 EST (-0500)
  Re: Compiling UberPOV on MacOSX  
From: clipka
Date: 4 Dec 2013 14:12:07
Message: <529f7e87$1@news.povray.org>
Am 04.12.2013 20:04, schrieb Bill Pragnell:
> clipka <ano### [at] anonymousorg> wrote:
>> I'd also like to kindly ask you to try compiling from this version:
>>
>> https://github.com/UberPOV/UberPOV/archive/feature/osx-support.zip
>>
>> It's supposed to build fine(*) on OS X now, but I need a guinea pig to
>> actually try it ;-)
>>
>>
>> (* except for the boost thing. You'll still need to add
>> LIBS="-lboost_system -lboost_thread" to the ./configure command to get
>> around that one; but that's not a Mac-specific issue.)
>
> The prebuild script works fine now, but configure still bails at the boost check
> even with your suggested LIBS switch, or with --with-boost and
> --with-boost-thread set as per many other 3.7 compilation newsgroup threads (my
> boost libs are installed in /opt/local/lib/, if that's relevant).

Can you give any additional details (what exactly configure is 
complaining about)?

You do have boost installed, do you?


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.