Le 22/07/2010 12:34, clipka nous fit lire :
> Am 22.07.2010 12:29, schrieb clipka:
>> I have only two points of critique:
>> (1) I think the computation of blockX and blockY should be done in one
>> single function, to prevent "fragmentation" of the mapping rules for
>> each case. (It is not uncommon in the POV-Ray code for a function to
>> have multiple output values.)
>> (2) Your code does not match the files' overall code formatting style :-P
> Oh, and (3) I can't make out what the "HG" in "HG_Render_Order" and
> "HGRO" stands for, so I'd suggest to reconsider those option names.
Go for it! Feel free to amend and do what ever you want with it.
Find & use any naming you like for (3).
I even agree with (1), it was just easier to try it that way (replacing
each formula with a function) as a plugged replacement. On a
production-source, it might be better to rethink it further: you're right.
For (2), do you have any documentation (or indent rules, in fact, I
would like the indent rules better, as autoformating is far easier than
following manual rules), I would be glad to set my editor (gvim) to
format the code (in any futur contribution, should it happen)
Post a reply to this message