POV-Ray : Newsgroups : povray.unix : ask help for Installation :) Server Time: 14 Dec 2018 09:49:05 GMT
  ask help for Installation :) (Message 1 to 10 of 11)  
Goto Latest 10 Messages Next 1 Messages >>>
From: Mengshi
Subject: ask help for Installation :)
Date: 19 May 2016 12:00:00
Message: <web.573daa1ab99d75a79a88d55e0@news.povray.org>
Hello everyone!!

I tried to install POV-Ray in my computer (SUSE Linux Enterprise Desktop 12
64-bit), but I got the error as following:

g++ -DHAVE_CONFIG_H -I. -I. -I..  -I.. -I../source/base -I../source/frontend
-I../unix    -pipe -Wno-multichar -O3 -msse -mfpmath=sse -msse2 -march=k8
-mtune=k8 -malign-double -minline-all-stringops  -c -o lighting.o `test -f
'lighting.cpp' || echo './'`lighting.cpp
Makefile:285: recipe for target 'lighting.o' failed


Could you help me know how to deal with that problem?


This is the output for your referece:

===============================================================================
Configure POV-Ray version 3.6.1
===============================================================================

This is an unofficial version compiled by:


Environment
-----------
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether $C_INCLUDE_PATH contains the "." path... no
checking whether $CPLUS_INCLUDE_PATH contains the "." path... no

Programs
--------
checking for egrep... grep -E
checking for style of include used by make... GNU
checking for g++... g++
checking for C++ compiler default output... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for g++ version... 4.8
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for ranlib... ranlib

Language constructs and functions
---------------------------------
checking whether to link with cygwin DLL... no
checking whether time.h and sys/time.h may both be included... yes
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for unistd.h... (cached) yes
checking for size_t... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for int... yes
checking size of int... 4
checking for long int... yes
checking size of long int... 8
checking for size_t... (cached) yes
checking size of size_t... 8
checking for float... yes
checking size of float... 4
checking for working memcmp... yes
checking return type of signal handlers... void
checking for vsnprintf... yes
checking for getcwd... yes
checking for readlink... yes
checking for gettimeofday... yes

Libraries
---------
checking whether to enable static linking... no
checking for sin in -lm... yes
checking for asinh... yes
checking for vga_init in -lvga... no
configure: SVGAlib display will be disabled
checking for X... libraries /usr/lib64, headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for XFlush in -lX11... yes
checking for XpmCreatePixmapFromData in -lXpm... yes
checking whether to enable the watch cursor... no
checking for installed supporting libraries... yes
checking for library containing zlibVersion... -lz
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for libz version >= 1.2.1... 1.2.8, ok
checking for library containing png_get_libpng_ver... -lpng
checking png.h usability... yes
checking png.h presence... yes
checking for png.h... yes
checking for libpng version >= 1.2.5... 1.6.8, ok
checking for library containing jpeg_std_error... -ljpeg
checking jpeglib.h usability... yes
checking jpeglib.h presence... yes
checking for jpeglib.h... yes
checking for libjpeg version >= 6b... 6b, ok
checking for library containing TIFFGetVersion... -ltiff
checking tiffio.h usability... yes
checking tiffio.h presence... yes
checking for tiffio.h... yes
checking for libtiff version >= 3.6.1... 4.0.4, ok

Compiling
---------
checking whether to enable pipes for communications... yes
checking whether g++ accepts -pipe... yes
checking whether g++ accepts -Wno-multichar... yes
checking whether to enable I/O restrictions... yes
checking whether to enable debugging... no
checking whether to enable profiling... no
checking whether to enable stripping... no
checking whether to enable optimizations... yes
checking whether g++ accepts -O3... yes
checking whether g++ accepts -msse... yes
checking whether g++ accepts -mfpmath=sse... yes
checking whether g++ accepts -msse2... yes
checking whether g++ accepts -march=k8 -mtune=k8... yes
checking whether g++ accepts -malign-double... yes
checking whether g++ accepts -minline-all-stringops... yes

Makefiles
---------
configure: creating ./config.status
config.status: creating Makefile
config.status: creating libraries/Makefile
config.status: creating source/base/Makefile
config.status: creating source/frontend/Makefile
config.status: creating source/Makefile
config.status: creating unix/Makefile
config.status: creating conf.h
config.status: conf.h is unchanged
config.status: executing depfiles commands

===============================================================================
POV-Ray 3.6.1 has been configured with the following features:
  I/O restrictions: enabled
  X Window display: enabled
  SVGAlib display : disabled

Type 'make' to build, and 'make install' to install all files in the hierarchy
/data/bin/raysar
===============================================================================

make  all-recursive
make[1]: Entering directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1'
Making all in libraries
make[2]: Entering directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/libraries'
make[3]: Entering directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/libraries'
make[3]: Nothing to be done for 'all-am'.
make[3]: Leaving directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/libraries'
make[2]: Leaving directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/libraries'
Making all in source
make[2]: Entering directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source'
Making all in base
make[3]: Entering directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source/base'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source/base'
Making all in frontend
make[3]: Entering directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source/frontend'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source/frontend'
make[3]: Entering directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source'
g++ -DHAVE_CONFIG_H -I. -I. -I..  -I.. -I../source/base -I../source/frontend
-I../unix    -pipe -Wno-multichar -O3 -msse -mfpmath=sse -msse2 -march=k8
-mtune=k8 -malign-double -minline-all-stringops  -c -o lighting.o `test -f
'lighting.cpp' || echo './'`lighting.cpp
Makefile:285: recipe for target 'lighting.o' failed
make[3]: Leaving directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source'
Makefile:298: recipe for target 'all-recursive' failed
make[2]: Leaving directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1/source'
Makefile:405: recipe for target 'all-recursive' failed
make[1]: Leaving directory
'/data/Code/raySAR/povary_package/povary_source/povray-3.6.1'
Makefile:237: recipe for target 'all' failed


Post a reply to this message

From: Le Forgeron
Subject: Re: ask help for Installation :)
Date: 19 May 2016 14:00:05
Message: <573dc6e5$1@news.povray.org>
Le 19/05/2016 à 13:57, Mengshi a écrit :
> Configure POV-Ray version 3.6.1

Do you really need and want to install 3.6 when 3.7 is available ?


Post a reply to this message

From: Mengshi
Subject: Re: ask help for Installation :)
Date: 19 May 2016 14:50:00
Message: <web.573dd1d74a9160d1782ea98c0@news.povray.org>
Le_Forgeron <lef### [at] freefr> wrote:
> Le 19/05/2016 à 13:57, Mengshi a écrit :
> > Configure POV-Ray version 3.6.1
>
> Do you really need and want to install 3.6 when 3.7 is available ?

Yes, I want to use a software which is based on the 3.6 version.


Post a reply to this message

From: Le Forgeron
Subject: Re: ask help for Installation :)
Date: 19 May 2016 15:43:39
Message: <573ddf2b$1@news.povray.org>
Le 19/05/2016 16:46, Mengshi a écrit :
> Le_Forgeron <lef### [at] freefr> wrote:
>> Le 19/05/2016 à  13:57, Mengshi a écrit :
>>> Configure POV-Ray version 3.6.1
>>
>> Do you really need and want to install 3.6 when 3.7 is available ?
> 
> Yes, I want to use a software which is based on the 3.6 version.
> 
> 

I'm afraid you are in for a bit of debugging, between the old code, your compiler and
the currently installed libraries.

You will also encounter a problem with the png library, as its API has changed (and
old code was not nice, using internal functions)

And I cannot help for lighting.o, as it compiles fine here (but png_pov.o is bad
enough by default, so no binary for me either)

g++ -DHAVE_CONFIG_H -I. -I. -I..  -I.. -I../source/base -I../source/frontend -I../unix
   -pipe -Wno-multichar -O3 -msse -mfpmath=sse -msse2 -march=k8 -mtune=k8
-malign-double -minline-all-stringops  -c -o lighting.o `test -f 'lighting.cpp' ||
echo './'`lighting.cpp


Post a reply to this message

From: Mengshi
Subject: Re: ask help for Installation :)
Date: 19 May 2016 16:50:01
Message: <web.573dee2f4a9160d1782ea98c0@news.povray.org>
Yes,yes,
I also have problem for png_pov.

But if I used version 3.7.
when I cd to /unix and try ./prebuild.sh
I just got :
requires automake 1.9 or above
:(((

Le_Forgeron <jgr### [at] freefr> wrote:
> Le 19/05/2016 16:46, Mengshi a écrit :
> > Le_Forgeron <lef### [at] freefr> wrote:
> >> Le 19/05/2016 à  13:57, Mengshi a écrit :
> >>> Configure POV-Ray version 3.6.1
> >>
> >> Do you really need and want to install 3.6 when 3.7 is available ?
> >
> > Yes, I want to use a software which is based on the 3.6 version.
> >
> >
>
> I'm afraid you are in for a bit of debugging, between the old code, your compiler
and the currently installed librari
es.
>
> You will also encounter a problem with the png library, as its API has changed (and
old code was not nice, using inte
rnal functions)
>
> And I cannot help for lighting.o, as it compiles fine here (but png_pov.o is bad
enough by default, so no binary for 
me either)
>
> g++ -DHAVE_CONFIG_H -I. -I. -I..  -I.. -I../source/base -I../source/frontend
-I../unix    -pipe -Wno-multichar -O3 -m
sse -mfpmath=sse -msse2 -march=k8 -mtune=k8 -malign-double -minline-all-stringops  -c
-o lighting.o `test -f 'lighting.
cpp' || echo './'`lighting.cpp


Post a reply to this message

From: Mengshi
Subject: Re: ask help for Installation :)
Date: 19 May 2016 16:55:00
Message: <web.573def2b4a9160d1782ea98c0@news.povray.org>
But I already have automake1.11

Le_Forgeron <jgr### [at] freefr> wrote:
> Le 19/05/2016 16:46, Mengshi a écrit :
> > Le_Forgeron <lef### [at] freefr> wrote:
> >> Le 19/05/2016 à  13:57, Mengshi a écrit :
> >>> Configure POV-Ray version 3.6.1
> >>
> >> Do you really need and want to install 3.6 when 3.7 is available ?
> >
> > Yes, I want to use a software which is based on the 3.6 version.
> >
> >
>
> I'm afraid you are in for a bit of debugging, between the old code, your compiler
and the currently installed librari
es.
>
> You will also encounter a problem with the png library, as its API has changed (and
old code was not nice, using inte
rnal functions)
>
> And I cannot help for lighting.o, as it compiles fine here (but png_pov.o is bad
enough by default, so no binary for 
me either)
>
> g++ -DHAVE_CONFIG_H -I. -I. -I..  -I.. -I../source/base -I../source/frontend
-I../unix    -pipe -Wno-multichar -O3 -m
sse -mfpmath=sse -msse2 -march=k8 -mtune=k8 -malign-double -minline-all-stringops  -c
-o lighting.o `test -f 'lighting.
cpp' || echo './'`lighting.cpp


Post a reply to this message

From: William F Pokorny
Subject: Re: ask help for Installation :)
Date: 19 May 2016 16:58:37
Message: <573df0bd$1@news.povray.org>
On 05/19/2016 10:46 AM, Mengshi wrote:
> Le_Forgeron <lef### [at] freefr> wrote:
>> Le 19/05/2016 à 13:57, Mengshi a écrit :
>>> Configure POV-Ray version 3.6.1
>>
>> Do you really need and want to install 3.6 when 3.7 is available ?
>
> Yes, I want to use a software which is based on the 3.6 version.
>
>

It's been a while since I did a 3.6 compile, but last time on Ubuntu 
14.04 I ran configure with:

./configure COMPILED_BY="WFP" --disable-lib-checks

to use the packaged libraries in the 3.6 tarball. However, with the 
above configure stopped when a mktime test subprocess hung in a loop. I 
had to manually kill the mktime subprocess after which configure finished.

I could then do:

make clean
make

successfully.

Bill P.


Post a reply to this message

From: Mengshi
Subject: Re: ask help for Installation :)
Date: 19 May 2016 17:15:01
Message: <web.573df48c4a9160d19a88d55e0@news.povray.org>
Nice!!!!!!!!

It's work!!!  :)
Thanks a lot!

William F Pokorny <ano### [at] anonymousorg> wrote:
> On 05/19/2016 10:46 AM, Mengshi wrote:
> > Le_Forgeron <lef### [at] freefr> wrote:
> >> Le 19/05/2016 à 13:57, Mengshi a écrit :
> >>> Configure POV-Ray version 3.6.1
> >>
> >> Do you really need and want to install 3.6 when 3.7 is available ?
> >
> > Yes, I want to use a software which is based on the 3.6 version.
> >
> >
>
> It's been a while since I did a 3.6 compile, but last time on Ubuntu
> 14.04 I ran configure with:
>
> ./configure COMPILED_BY="WFP" --disable-lib-checks
>
> to use the packaged libraries in the 3.6 tarball. However, with the
> above configure stopped when a mktime test subprocess hung in a loop. I
> had to manually kill the mktime subprocess after which configure finished.
>
> I could then do:
>
> make clean
> make
>
> successfully.
>
> Bill P.


Post a reply to this message

From: clipka
Subject: Re: ask help for Installation :)
Date: 19 May 2016 17:46:04
Message: <573dfbdc$1@news.povray.org>
Am 19.05.2016 um 13:57 schrieb Mengshi:
> Hello everyone!!
> 
> I tried to install POV-Ray in my computer (SUSE Linux Enterprise Desktop 12
> 64-bit), but I got the error as following:
> 
> g++ -DHAVE_CONFIG_H -I. -I. -I..  -I.. -I../source/base -I../source/frontend
> -I../unix    -pipe -Wno-multichar -O3 -msse -mfpmath=sse -msse2 -march=k8
> -mtune=k8 -malign-double -minline-all-stringops  -c -o lighting.o `test -f
> 'lighting.cpp' || echo './'`lighting.cpp
> Makefile:285: recipe for target 'lighting.o' failed

You _definitely_ should contact the author of RaySAR for support, as the
POV-Ray coming with RaySAR is a patched version, and lighting.cpp is one
of the patched files.

One thing I've noticed about the modified files is that they have
DOS-style line endings (CR+LF) instead of Unix-style line endings (LF);
maybe those need to be converted.

Another thing I've noticed is that the patched lighting.cpp includes a
file called "povproto.h", which for some reason does not reside in
povray_linux_source/povray-3.6.tar, but in povray_linux_source itself.
Maybe the installation instructions fail to cover that file properly.


Just for fun, you might try compiling the unmodified POV-Ray 3.6.1
(ideally from an authoritative source, i.e. www.povray.org, rather than
the povray-3.6.tar included in RaySAR) to verify that the problems arise
from the modifications rather than a general incompatibility between
POV-Ray 3.6.1 and your build environment.


Post a reply to this message

From: clipka
Subject: Re: ask help for Installation :)
Date: 19 May 2016 17:54:18
Message: <573dfdca$1@news.povray.org>
Am 19.05.2016 um 18:47 schrieb Mengshi:
> Yes,yes,
> I also have problem for png_pov.
> 
> But if I used version 3.7.
> when I cd to /unix and try ./prebuild.sh
> I just got :
> requires automake 1.9 or above
> :(((

If you have automake 1.11, but get an error message saying you need
automake 1.9 or above, there's something fishy going on, and I'd like to
know more about it.

That said, it probably won't help with RaySAR anyway, as that program
seems to require a patched version of POV-Ray.


Post a reply to this message

Goto Latest 10 Messages Next 1 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.