POV-Ray : Newsgroups : povray.unix : Cannot link boost thread (libboost v1.59) Server Time: 14 Dec 2018 10:22:44 GMT
  Cannot link boost thread (libboost v1.59) (Message 1 to 8 of 8)  
From: MadKairon
Subject: Cannot link boost thread (libboost v1.59)
Date: 25 Nov 2015 19:05:01
Message: <web.565605807bc0f81e7d082a680@news.povray.org>
Still trying to compile Master Branch on Raspbian Jessie. As the boost
distribution in the repositry didn't work I removed it, downloaded libboost 1.59
and installed it. ./prebuild.sh goes ok, then configure process fails when
checking boost thread and stops. This is the new error. Is there any way to fix
it?

Libraries
---------
checking whether to link with cygwin DLL... no
checking whether to enable static linking... no
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking for boostlib >= 1.38... yes
checking whether the Boost::Thread library is available... yes
checking for exit in -lboost_thread... yes
checking whether the boost thread library is usable... no
configure: error: in `/home/pi/povray-master':
configure: error: cannot link with the boost thread library
See `config.log' for more details


Post a reply to this message

From: LanuHum
Subject: Re: Cannot link boost thread (libboost v1.59)
Date: 25 Nov 2015 19:45:01
Message: <web.56560e9840b64f67a3e03fe0@news.povray.org>
"MadKairon" <nomail@nomail> wrote:
> Still trying to compile Master Branch on Raspbian Jessie. As the boost
> distribution in the repositry didn't work I removed it, downloaded libboost 1.59
> and installed it. ./prebuild.sh goes ok, then configure process fails when
> checking boost thread and stops. This is the new error. Is there any way to fix
> it?
>
../configure LIBS="-lboost_system -lboost_thread -lboost_date_time"


Post a reply to this message

From: MadKairon
Subject: Re: Cannot link boost thread (libboost v1.59)
Date: 25 Nov 2015 19:55:00
Message: <web.5656116340b64f67d082a680@news.povray.org>
"LanuHum" <Lan### [at] yandexru> wrote:
> "MadKairon" <nomail@nomail> wrote:
> > Still trying to compile Master Branch on Raspbian Jessie. As the boost
> > distribution in the repositry didn't work I removed it, downloaded libboost 1.59
> > and installed it. ./prebuild.sh goes ok, then configure process fails when
> > checking boost thread and stops. This is the new error. Is there any way to fix
> > it?
> >
> ../configure LIBS="-lboost_system -lboost_thread -lboost_date_time"

Well, this didn't work :(

../configure COMPILED_BY="MadKairon on RPi 2" LIBS="-lboost_system -lboost_thread
-lboost_date_time"

===============================================================================
Configure POV-Ray version 3.7.1-alpha.8353331
===============================================================================

This is an unofficial version compiled by:
 MadKairon on RPi 2
The POV-Ray Team(tm) is not responsible for supporting this version.

Environment
-----------
checking build system type... armv7l-unknown-linux-gnueabihf
checking host system type... armv7l-unknown-linux-gnueabihf
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether $C_INCLUDE_PATH contains the "." path... no
checking whether $CPLUS_INCLUDE_PATH contains the "." path... no

Programs
--------
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... configure: error: in
`/home/pi/povray-master':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details


Post a reply to this message

From: clipka
Subject: Re: Cannot link boost thread (libboost v1.59)
Date: 25 Nov 2015 22:48:07
Message: <56563aa7$1@news.povray.org>
Am 25.11.2015 um 20:01 schrieb MadKairon:
> Still trying to compile Master Branch on Raspbian Jessie. As the boost
> distribution in the repositry didn't work I removed it, downloaded libboost 1.59
> and installed it. ./prebuild.sh goes ok, then configure process fails when
> checking boost thread and stops. This is the new error. Is there any way to fix
> it?

Maybe. Or maybe not. We'd need to...:

> See `config.log' for more details

;)


Post a reply to this message

From: MadKairon
Subject: Re: Cannot link boost thread (libboost v1.59)
Date: 26 Nov 2015 02:15:01
Message: <web.5656695640b64f67d082a680@news.povray.org>
clipka <ano### [at] anonymousorg> wrote:
> Am 25.11.2015 um 20:01 schrieb MadKairon:
> > Still trying to compile Master Branch on Raspbian Jessie. As the boost
> > distribution in the repositry didn't work I removed it, downloaded libboost 1.59
> > and installed it. ./prebuild.sh goes ok, then configure process fails when
> > checking boost thread and stops. This is the new error. Is there any way to fix
> > it?
>
> Maybe. Or maybe not. We'd need to...:
>
> > See `config.log' for more details
>
> ;)

Errr... well, that was the first thing I tried. All I can say is the words
"Fatal error" repeat a few times. Sorry, n00b here!

This is the config.log file when I try ./configure COMPILED_BY="MadKairon on RPi
2"

http://www.kungfuzn.com.ar/imagenes/config.log


Post a reply to this message

From: clipka
Subject: Re: Cannot link boost thread (libboost v1.59)
Date: 26 Nov 2015 11:05:00
Message: <web.5656e6f040b64f6ad6fa18f0@news.povray.org>
"MadKairon" <nomail@nomail> wrote:
> clipka <ano### [at] anonymousorg> wrote:
> > Am 25.11.2015 um 20:01 schrieb MadKairon:
> > > Still trying to compile Master Branch on Raspbian Jessie. As the boost
> > > distribution in the repositry didn't work I removed it, downloaded libboost 1.59
> > > and installed it. ./prebuild.sh goes ok, then configure process fails when
> > > checking boost thread and stops. This is the new error. Is there any way to fix
> > > it?
> >
> > Maybe. Or maybe not. We'd need to...:
> >
> > > See `config.log' for more details
> >
> > ;)
>
> Errr... well, that was the first thing I tried. All I can say is the words
> "Fatal error" repeat a few times. Sorry, n00b here!
>
> This is the config.log file when I try ./configure COMPILED_BY="MadKairon on RPi
> 2"
>
> http://www.kungfuzn.com.ar/imagenes/config.log

It might be all Greek to you, but it sometimes gives us a clue over here ;)

The "Fatal error" messages in config.log are not necessarily a reason for
concern: The ./configure script tries to compile some small test programs to
figure out how the build environment behaves, and sometimes it needs a few
attempts before it finds the correct combination of parameters to achieve some
desired effect; also, some of the test programs deliberately can't compile, to
see how the build environment reacts to errors.


In your case, what I see is that your linker appears to be convinced that the
boost library should have the file name libboost_thread.so.1.59.0, while in
reality there doesn't seem to be a library file of that exact name.

I gather from your original post that you have built the boost 1.59 library
yourself, rather than download it via a package maneger.

The internet claims that running "sudo ldconfig" might solve your problem.

Alternatively, you could figure out the actual name of the library file, and
link specifically to that file using the --with-boost-thread parameter.


Post a reply to this message

From: MadKairon
Subject: Re: Cannot link boost thread (libboost v1.59)
Date: 26 Nov 2015 11:20:01
Message: <web.5656ea3940b64f67d082a680@news.povray.org>
WAIT!!

I think I skipped one of this 2:

sudo apt-get -y install libsdl-dev
sudo apt-get -y install libtiff-dev

../configure process finished ok now!

I'll post the results on: "make" and "sudo make install"


Post a reply to this message

From: clipka
Subject: Re: Cannot link boost thread (libboost v1.59)
Date: 26 Nov 2015 18:15:06
Message: <56574c2a@news.povray.org>
Am 26.11.2015 um 12:17 schrieb MadKairon:
> WAIT!!
> 
> I think I skipped one of this 2:
> 
> sudo apt-get -y install libsdl-dev
> sudo apt-get -y install libtiff-dev
> 
> .../configure process finished ok now!

That's noticeably weird: The ./configure output and config.log you
posted seem to indicate that the script didn't even reach the phase
where those libs would make a difference -- and if the script would miss
them it would just disable the preview display and support for the .tif
image file format.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.