POV-Ray : Newsgroups : povray.unix : compile error on Raspbian: Boost Thread library version not found Server Time: 14 Dec 2018 10:43:11 GMT
  compile error on Raspbian: Boost Thread library version not found (Message 1 to 7 of 7)  
From: MadKairon
Subject: compile error on Raspbian: Boost Thread library version not found
Date: 9 Nov 2015 18:00:00
Message: <web.5640de07a8e6d3fe48dea6910@news.povray.org>
Hi,

I am trying to compile POV-Ray on a Raspberry Pi 2. Master branch throws this
message when compiling and stops:

Libraries
---------
checking whether to link with cygwin DLL... no
checking whether to enable static linking... no
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking for boostlib >= 1.38... yes
checking whether the Boost::Thread library is available... yes
configure: error: Could not find a version of the library!

Any clues? I am kinda new to this. I always ran POV-Ray on windows.


Post a reply to this message

From: Le Forgeron
Subject: Re: compile error on Raspbian: Boost Thread library version not found
Date: 9 Nov 2015 21:38:56
Message: <56411270$1@news.povray.org>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Le 09/11/2015 18:55, MadKairon a écrit :
> Hi,
> 
> I am trying to compile POV-Ray on a Raspberry Pi 2. Master branch
> throws this message when compiling and stops:
> 
> Libraries --------- checking whether to link with cygwin DLL... no 
> checking whether to enable static linking... no checking for the
> pthreads library -lpthreads... no checking whether pthreads work
> without any flags... no checking whether pthreads work with
> -Kthread... no checking whether pthreads work with -kthread... no 
> checking for the pthreads library -llthread... no checking whether
> pthreads work with -pthread... yes checking for joinable pthread
> attribute... PTHREAD_CREATE_JOINABLE checking if more special flags
> are required for pthreads... no checking for boostlib >= 1.38...
> yes checking whether the Boost::Thread library is available... yes 
> configure: error: Could not find a version of the library!
> 
> Any clues? I am kinda new to this. I always ran POV-Ray on
> windows.
> 
> 
usually (well, with modern boost library), you might need to add
LIBS="-lboost_system -lboost_thread" to the parameters of config

Someothers did compile for the rasberry pi, so they might give better
help.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iJwEAQEIAAYFAlZBEm8ACgkQhKAm8mTpkW1jRQQA2WsyTGbyH7Ob1ik2a0Q7KXZ2
6p7epvOVR/3Y8Ji/Sxihb+1P0kFN2nIem2ys+rSXgLoBlurqdjjebTiYm4TUiHRa
JqWodev86oBy6tQuSLNZKlxhOIRJWHyQYyNlZAWv/mXdU1J2S9T9yihY6qHrrKcN
Gh9tqzodEiu1MaiIvVI=
=WreH
-----END PGP SIGNATURE-----


Post a reply to this message

From: MadKairon
Subject: Re: compile error on Raspbian: Boost Thread library version not found
Date: 10 Nov 2015 03:05:00
Message: <web.56415df8841b54df43f93d110@news.povray.org>
> usually (well, with modern boost library), you might need to add
> LIBS="-lboost_system -lboost_thread" to the parameters of config
>
> Someothers did compile for the rasberry pi, so they might give better
> help.
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
>
> iJwEAQEIAAYFAlZBEm8ACgkQhKAm8mTpkW1jRQQA2WsyTGbyH7Ob1ik2a0Q7KXZ2
> 6p7epvOVR/3Y8Ji/Sxihb+1P0kFN2nIem2ys+rSXgLoBlurqdjjebTiYm4TUiHRa
> JqWodev86oBy6tQuSLNZKlxhOIRJWHyQYyNlZAWv/mXdU1J2S9T9yihY6qHrrKcN
> Gh9tqzodEiu1MaiIvVI=
> =WreH
> -----END PGP SIGNATURE-----

Tried adding those parameters to the config but did not work. No one has
compiled it with the modern boost nor latest versions of automake. Master Branch
solves the atomake problems tho.


Post a reply to this message

From: Nerdifant
Subject: Re: compile error on Raspbian: Boost Thread library version not found
Date: 13 Jun 2017 12:45:00
Message: <web.593fdd81841b54dfbbe07c920@news.povray.org>
"MadKairon" <nomail@nomail> wrote:
> > usually (well, with modern boost library), you might need to add
> > LIBS="-lboost_system -lboost_thread" to the parameters of config
> >
> > Someothers did compile for the rasberry pi, so they might give better
> > help.
> > -----BEGIN PGP SIGNATURE-----
> > Version: GnuPG v2
> >
> > iJwEAQEIAAYFAlZBEm8ACgkQhKAm8mTpkW1jRQQA2WsyTGbyH7Ob1ik2a0Q7KXZ2
> > 6p7epvOVR/3Y8Ji/Sxihb+1P0kFN2nIem2ys+rSXgLoBlurqdjjebTiYm4TUiHRa
> > JqWodev86oBy6tQuSLNZKlxhOIRJWHyQYyNlZAWv/mXdU1J2S9T9yihY6qHrrKcN
> > Gh9tqzodEiu1MaiIvVI=
> > =WreH
> > -----END PGP SIGNATURE-----
>
> Tried adding those parameters to the config but did not work. No one has
> compiled it with the modern boost nor latest versions of automake. Master Branch
> solves the atomake problems tho.


Tryin' to configure the compilation on raspberrypi (raspbian)
Same error:

Command

pi@raspberrypi:~/povray $ ./configure --prefix=$HOME/opt/povray
COMPILED_BY="MCL"  LIBS="-lboost_system -lboost_thread"

....


Libraries
---------
checking whether to link with cygwin DLL... no
checking whether to enable static linking... no
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking for boostlib >= 1.37... yes
checking whether the Boost::Thread library is available... yes
configure: error: Could not find a version of the library!

Any tips to solve this issue ?


Thx !


Post a reply to this message

From: Le Forgeron
Subject: Re: compile error on Raspbian: Boost Thread library version not found
Date: 13 Jun 2017 14:25:22
Message: <593ff5d2@news.povray.org>
Le 13/06/2017 à 14:41, Nerdifant a écrit :
> "MadKairon" <nomail@nomail> wrote:

>> Tried adding those parameters to the config but did not work. No one has
>> compiled it with the modern boost nor latest versions of automake. Master Branch
>> solves the atomake problems tho.
> 
> 
> Tryin' to configure the compilation on raspberrypi (raspbian)
> Same error:
> 
> Command
> 
> pi@raspberrypi:~/povray $ ./configure --prefix=$HOME/opt/povray
> COMPILED_BY="MCL"  LIBS="-lboost_system -lboost_thread"
> 
> ....


Is it the stable or master branch you are trying to compile ?

> 
> 
> Libraries
> ---------
> checking whether to link with cygwin DLL... no
> checking whether to enable static linking... no
> checking for the pthreads library -lpthreads... no
> checking whether pthreads work without any flags... no
> checking whether pthreads work with -Kthread... no
> checking whether pthreads work with -kthread... no
> checking for the pthreads library -llthread... no
> checking whether pthreads work with -pthread... yes
> checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
> checking if more special flags are required for pthreads... no
> checking for boostlib >= 1.37... yes
> checking whether the Boost::Thread library is available... yes
> configure: error: Could not find a version of the library!
> 
> Any tips to solve this issue ?
> 
> 
> Thx !
> 
> 
> 
> 
> 
>


Post a reply to this message

From: William F Pokorny
Subject: Re: compile error on Raspbian: Boost Thread library version not found
Date: 13 Jun 2017 16:06:34
Message: <59400d8a$1@news.povray.org>
On 06/13/2017 08:41 AM, Nerdifant wrote:
> "MadKairon" <nomail@nomail> wrote:
>>> usually (well, with modern boost library), you might need to add
>>> LIBS="-lboost_system -lboost_thread" to the parameters of config
>>>
...
>>
>> Tried adding those parameters to the config but did not work. No one has
>> compiled it with the modern boost nor latest versions of automake. Master Branch
>> solves the atomake problems tho.
> 
> 
> Tryin' to configure the compilation on raspberrypi (raspbian)
> Same error:
> 
> Command
> 
> pi@raspberrypi:~/povray $ ./configure --prefix=$HOME/opt/povray
> COMPILED_BY="MCL"  LIBS="-lboost_system -lboost_thread"
> 
> ....
> 
> 
> Libraries
> ---------
> checking whether to link with cygwin DLL... no
> checking whether to enable static linking... no
> checking for the pthreads library -lpthreads... no
> checking whether pthreads work without any flags... no
> checking whether pthreads work with -Kthread... no
> checking whether pthreads work with -kthread... no
> checking for the pthreads library -llthread... no
> checking whether pthreads work with -pthread... yes
> checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
> checking if more special flags are required for pthreads... no
> checking for boostlib >= 1.37... yes
> checking whether the Boost::Thread library is available... yes
> configure: error: Could not find a version of the library!
> 
> Any tips to solve this issue ?
> 
> 
> Thx !
> 

Could you perhaps try adding an explicit pointer to the installed boost 
library on the ./configure command? For me on Ubuntu this looks 
something like:

./configure ... --with-boost-libdir=/usr/lib/x86_64-linux-gnu

on the Raspberry Pi the boost location will likely be different.

If you go to your <povrayRoot>/unix/config you should find a sym link 
back to the automake config.guess script. Try to run it via 
./config.guess and see what it returns.

If nothing reasonable, perhaps this the core issue on your set up. 
Otherwise, see if the boost library is located in something like:

/usr/lib/<config.guess's return string>

you can use:

ls /usr/lib/<config.guess'a return string>/libboost*

to verify the archive (.a) and shared library (.so) boost files are there.

Aside 1 : Looks like our --with-boost[=ARG] build option isn't properly 
set up and somewhat redundant by description with --with-boost-libdir.

Aside 2 : Curious, are any of you Pi folks looking at Pi clusters?

Bill P.


Post a reply to this message

From: William F Pokorny
Subject: Re: compile error on Raspbian: Boost Thread library version not found
Date: 24 Jun 2017 21:14:14
Message: <594ed626$1@news.povray.org>
On 11/09/2015 12:55 PM, MadKairon wrote:
> Hi,
> 
> I am trying to compile POV-Ray on a Raspberry Pi 2. Master branch throws this
> message when compiling and stops:
> 
> Libraries
> ---------
> checking whether to link with cygwin DLL... no
> checking whether to enable static linking... no
> checking for the pthreads library -lpthreads... no
> checking whether pthreads work without any flags... no
> checking whether pthreads work with -Kthread... no
> checking whether pthreads work with -kthread... no
> checking for the pthreads library -llthread... no
> checking whether pthreads work with -pthread... yes
> checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
> checking if more special flags are required for pthreads... no
> checking for boostlib >= 1.38... yes
> checking whether the Boost::Thread library is available... yes
> configure: error: Could not find a version of the library!
> 
> Any clues? I am kinda new to this. I always ran POV-Ray on windows.
> 
> 

Reference github issue:

https://github.com/POV-Ray/povray/issues/300

User reported the following worked as a patch for the ./configure 
failure in this thread:

./configure COMPILED_BY="Mausy5043" 
--with-boost-libdir=/usr/lib/arm-linux-gnueabihf

Bill P.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.