POV-Ray : Newsgroups : povray.unix : Unable to import povray in python Server Time: 17 Jun 2019 12:36:20 GMT
  Unable to import povray in python (Message 1 to 5 of 5)  
From: Florent
Subject: Unable to import povray in python
Date: 7 Nov 2014 13:15:01
Message: <web.545cc4b1b82257bf5fe92c6f0@news.povray.org>
Hello,

The program I use to model particle interactions provides visualization through
povray. Despite my best attempts, I can' import povray into python 2.7.8 on
Ubuntu 14.10:

$  python
Python 2.7.8 (default, Oct 20 2014, 15:05:29)
[GCC 4.9.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import povray
Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
ImportError: No module named povray
>>>


I first tried using the prepackaged version from apt-get, then uninstalled it
and manually compiled the github library. Same non-result, but povray seems to
be installed just fine.

Any help would be greatly appreciated !
Florent


Post a reply to this message

From: clipka
Subject: Re: Unable to import povray in python
Date: 7 Nov 2014 16:48:59
Message: <545cf7fb$1@news.povray.org>
Am 07.11.2014 14:14, schrieb Florent:
> Hello,
>
> The program I use to model particle interactions provides visualization through
> povray. Despite my best attempts, I can' import povray into python 2.7.8 on
> Ubuntu 14.10:
>
> $  python
> Python 2.7.8 (default, Oct 20 2014, 15:05:29)
> [GCC 4.9.1] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
>>>> import povray
> Traceback (most recent call last):
>      File "<stdin>", line 1, in <module>
> ImportError: No module named povray

Um... I'm not a python expert, so I may be misunderstanding things, but 
you do know that POV-Ray is just a binary executable, _not_ a python 
module..?


Post a reply to this message

From: LanuHum
Subject: Re: Unable to import povray in python
Date: 7 Nov 2014 19:00:01
Message: <web.545d15d89ffcae67113a021b0@news.povray.org>
"Florent" <nomail@nomail> wrote:
> Hello,
>
> The program I use to model particle interactions provides visualization through
> povray. Despite my best attempts, I can' import povray into python 2.7.8 on
> Ubuntu 14.10:
>
> $  python
> Python 2.7.8 (default, Oct 20 2014, 15:05:29)
> [GCC 4.9.1] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import povray
> Traceback (most recent call last):
>     File "<stdin>", line 1, in <module>
> ImportError: No module named povray
> >>>
>
>
> I first tried using the prepackaged version from apt-get, then uninstalled it
> and manually compiled the github library. Same non-result, but povray seems to
> be installed just fine.
>
> Any help would be greatly appreciated !
> Florent

How we can guess? Where program code?


Post a reply to this message

From: Doctor John
Subject: Re: Unable to import povray in python
Date: 7 Nov 2014 21:36:49
Message: <545d3b71$1@news.povray.org>
On 07/11/14 13:14, Florent wrote:
> Hello,
> 
> The program I use to model particle interactions provides visualization through
> povray. Despite my best attempts, I can' import povray into python 2.7.8 on
> Ubuntu 14.10:
> 
> $  python
> Python 2.7.8 (default, Oct 20 2014, 15:05:29)
> [GCC 4.9.1] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
>>>> import povray
> Traceback (most recent call last):
>     File "<stdin>", line 1, in <module>
> ImportError: No module named povray
>>>>
> 
> 
> I first tried using the prepackaged version from apt-get, then uninstalled it
> and manually compiled the github library. Same non-result, but povray seems to
> be installed just fine.
> 
> Any help would be greatly appreciated !
> Florent
> 
> 

I'm not going to say RTFM, but bear in mind that subprocess and os are
modules that will help you.

So:
import subprocess, os
			will help

Without further details I can't really help more.

John
-- 
Protect the Earth
It was not given to you by your parents
You hold it in trust for your children


Post a reply to this message

From: Doctor John
Subject: Re: Unable to import povray in python
Date: 7 Nov 2014 22:02:48
Message: <545d4188$1@news.povray.org>
On 07/11/14 21:37, Doctor John wrote:
> 
> I'm not going to say RTFM, but bear in mind that subprocess and os are
> modules that will help you.
> 
> So:
> import subprocess, os
> 			will help
> 
> Without further details I can't really help more.
> 
> John
> 

Have a look at
http://www.pythonforbeginners.com/os/subprocess-for-system-administrators

This might give a few pointers

John
-- 
Protect the Earth
It was not given to you by your parents
You hold it in trust for your children


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.