POV-Ray : Newsgroups : povray.unix : Installation problem in povray subdivision on server. Server Time: 16 Jun 2019 06:43:47 GMT
  Installation problem in povray subdivision on server. (Message 1 to 10 of 12)  
Goto Latest 10 Messages Next 2 Messages >>>
From: Suman
Subject: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 10:45:01
Message: <web.53de12643d3a69d306240250@news.povray.org>
Hi,

i installed povray with full source on server and moved the files of povray
subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder then i
installed povray on centos server. povray is working fine but povray subdivision
is not working.

when i using code below.

mesh2 {

subdivision{     // subdivision
     substeps 2    // subdivide 2 times
  }
vertex_vectors {
.....

its showing error.

Please help me to solve the installation issue.

Thanks
Suman


Post a reply to this message

From: James Holsenback
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 10:59:47
Message: <53de1623@news.povray.org>
On 08/03/2014 06:43 AM, Suman wrote:
> Hi,
>
> i installed povray with full source on server and moved the files of povray
> subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder then i
> installed povray on centos server. povray is working fine but povray subdivision
> is not working.
>
> when i using code below.
>
> mesh2 {
>
> subdivision{     // subdivision
>       substeps 2    // subdivide 2 times
>    }
> vertex_vectors {
> .....
>
> its showing error.
>
> Please help me to solve the installation issue.
>
> Thanks
> Suman
>
>

you didn't say where you got povray source code ... what version? the 
subdivision files were last updated in 2004 so if you used version 3.7 
povray source code there may be incompatibilities ... MANY things have 
changed since version 3.6

did you notice any compile errors when you added the subdivision files 
to the povray source tree?


Post a reply to this message

From: Suman
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 11:20:04
Message: <web.53de19b33102494a306240250@news.povray.org>
Hi James,

i downloaded POV-Ray Source Code here
http://www.povray.org/download/index-3.6.php
and update the source files of povray subdivision
from(http://www.cise.ufl.edu/~xwu/Pov-Sub/).

i used the following command
../configure COMPILED_BY="your name <email@address>" [options]
  make check
  make install

but after installation subdivision is not working.

Thanks
Suman



James Holsenback <nom### [at] nonecom> wrote:
> On 08/03/2014 06:43 AM, Suman wrote:
> > Hi,
> >
> > i installed povray with full source on server and moved the files of povray
> > subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder then i
> > installed povray on centos server. povray is working fine but povray subdivision
> > is not working.
> >
> > when i using code below.
> >
> > mesh2 {
> >
> > subdivision{     // subdivision
> >       substeps 2    // subdivide 2 times
> >    }
> > vertex_vectors {
> > .....
> >
> > its showing error.
> >
> > Please help me to solve the installation issue.
> >
> > Thanks
> > Suman
> >
> >
>
> you didn't say where you got povray source code ... what version? the
> subdivision files were last updated in 2004 so if you used version 3.7
> povray source code there may be incompatibilities ... MANY things have
> changed since version 3.6
>
> did you notice any compile errors when you added the subdivision files
> to the povray source tree?


Post a reply to this message

From: James Holsenback
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 11:27:07
Message: <53de1c8b$1@news.povray.org>
On 08/03/2014 07:14 AM, Suman wrote:
> Hi James,
>
> i downloaded POV-Ray Source Code here
> http://www.povray.org/download/index-3.6.php
> and update the source files of povray subdivision
> from(http://www.cise.ufl.edu/~xwu/Pov-Sub/).
>
> i used the following command
> ../configure COMPILED_BY="your name <email@address>" [options]
>    make check
>    make install

Did you notice any errors or warnings from either the configure or make 
process?
>
> but after installation subdivision is not working.

not working how ... does it even recognize any of the keywords 
associated with the subdivision patch?

>
> Thanks
> Suman
>
>
>
> James Holsenback <nom### [at] nonecom> wrote:
>> On 08/03/2014 06:43 AM, Suman wrote:
>>> Hi,
>>>
>>> i installed povray with full source on server and moved the files of povray
>>> subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder then i
>>> installed povray on centos server. povray is working fine but povray subdivision
>>> is not working.
>>>
>>> when i using code below.
>>>
>>> mesh2 {
>>>
>>> subdivision{     // subdivision
>>>        substeps 2    // subdivide 2 times
>>>     }
>>> vertex_vectors {
>>> .....
>>>
>>> its showing error.
>>>
>>> Please help me to solve the installation issue.
>>>
>>> Thanks
>>> Suman
>>>
>>>
>>
>> you didn't say where you got povray source code ... what version? the
>> subdivision files were last updated in 2004 so if you used version 3.7
>> povray source code there may be incompatibilities ... MANY things have
>> changed since version 3.6
>>
>> did you notice any compile errors when you added the subdivision files
>> to the povray source tree?
>
>
>
>


Post a reply to this message

From: Suman
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 11:50:01
Message: <web.53de211d3102494a306240250@news.povray.org>
i did not notice any error during installation.
i am using exec command for image generation online.

exec("/usr/local/bin/povray ...");
and no error is showing.


James Holsenback <nom### [at] nonecom> wrote:
> On 08/03/2014 07:14 AM, Suman wrote:
> > Hi James,
> >
> > i downloaded POV-Ray Source Code here
> > http://www.povray.org/download/index-3.6.php
> > and update the source files of povray subdivision
> > from(http://www.cise.ufl.edu/~xwu/Pov-Sub/).
> >
> > i used the following command
> > ../configure COMPILED_BY="your name <email@address>" [options]
> >    make check
> >    make install
>
> Did you notice any errors or warnings from either the configure or make
> process?
> >
> > but after installation subdivision is not working.
>
> not working how ... does it even recognize any of the keywords
> associated with the subdivision patch?
>
> >
> > Thanks
> > Suman
> >
> >
> >
> > James Holsenback <nom### [at] nonecom> wrote:
> >> On 08/03/2014 06:43 AM, Suman wrote:
> >>> Hi,
> >>>
> >>> i installed povray with full source on server and moved the files of povray
> >>> subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder then i
> >>> installed povray on centos server. povray is working fine but povray subdivision
> >>> is not working.
> >>>
> >>> when i using code below.
> >>>
> >>> mesh2 {
> >>>
> >>> subdivision{     // subdivision
> >>>        substeps 2    // subdivide 2 times
> >>>     }
> >>> vertex_vectors {
> >>> .....
> >>>
> >>> its showing error.
> >>>
> >>> Please help me to solve the installation issue.
> >>>
> >>> Thanks
> >>> Suman
> >>>
> >>>
> >>
> >> you didn't say where you got povray source code ... what version? the
> >> subdivision files were last updated in 2004 so if you used version 3.7
> >> povray source code there may be incompatibilities ... MANY things have
> >> changed since version 3.6
> >>
> >> did you notice any compile errors when you added the subdivision files
> >> to the povray source tree?
> >
> >
> >
> >


Post a reply to this message

From: James Holsenback
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 11:50:20
Message: <53de21fc$1@news.povray.org>
On 08/03/2014 06:59 AM, James Holsenback wrote:
> On 08/03/2014 06:43 AM, Suman wrote:
>> Hi,
>>
>> i installed povray with full source on server and moved the files of
>> povray
>> subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder
>> then i
>> installed povray on centos server. povray is working fine but povray
>> subdivision
>> is not working.
>>
>> when i using code below.
>>
>> mesh2 {
>>
>> subdivision{     // subdivision
>>       substeps 2    // subdivide 2 times
>>    }
>> vertex_vectors {
>> .....
>>
>> its showing error.
>>
>> Please help me to solve the installation issue.
>>
>> Thanks
>> Suman
>>
>>
>
> you didn't say where you got povray source code ... what version? the
> subdivision files were last updated in 2004 so if you used version 3.7
> povray source code there may be incompatibilities ... MANY things have
> changed since version 3.6

unless the subdivision patch is a /must/ you should consider moving to 
version 3.7 ... here's a summary of what's changed:

http://wiki.povray.org/content/Documentation:Tutorial_Section_1#Changes_and_New_Features_Summary


Post a reply to this message

From: James Holsenback
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 11:58:44
Message: <53de23f4$1@news.povray.org>
On 08/03/2014 07:46 AM, Suman wrote:
> i did not notice any error during installation.
> i am using exec command for image generation online.
>
> exec("/usr/local/bin/povray ...");
> and no error is showing.

yeah ok then ... i'll ask again not working how? does it even recognize 
any keywords associated with the subdivision patch ... do you even get a 
complete render?

>
>
> James Holsenback <nom### [at] nonecom> wrote:
>> On 08/03/2014 07:14 AM, Suman wrote:
>>> Hi James,
>>>
>>> i downloaded POV-Ray Source Code here
>>> http://www.povray.org/download/index-3.6.php
>>> and update the source files of povray subdivision
>>> from(http://www.cise.ufl.edu/~xwu/Pov-Sub/).
>>>
>>> i used the following command
>>> ../configure COMPILED_BY="your name <email@address>" [options]
>>>     make check
>>>     make install
>>
>> Did you notice any errors or warnings from either the configure or make
>> process?
>>>
>>> but after installation subdivision is not working.
>>
>> not working how ... does it even recognize any of the keywords
>> associated with the subdivision patch?
>>
>>>
>>> Thanks
>>> Suman
>>>
>>>
>>>
>>> James Holsenback <nom### [at] nonecom> wrote:
>>>> On 08/03/2014 06:43 AM, Suman wrote:
>>>>> Hi,
>>>>>
>>>>> i installed povray with full source on server and moved the files of povray
>>>>> subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder then i
>>>>> installed povray on centos server. povray is working fine but povray subdivision
>>>>> is not working.
>>>>>
>>>>> when i using code below.
>>>>>
>>>>> mesh2 {
>>>>>
>>>>> subdivision{     // subdivision
>>>>>         substeps 2    // subdivide 2 times
>>>>>      }
>>>>> vertex_vectors {
>>>>> .....
>>>>>
>>>>> its showing error.
>>>>>
>>>>> Please help me to solve the installation issue.
>>>>>
>>>>> Thanks
>>>>> Suman
>>>>>
>>>>>
>>>>
>>>> you didn't say where you got povray source code ... what version? the
>>>> subdivision files were last updated in 2004 so if you used version 3.7
>>>> povray source code there may be incompatibilities ... MANY things have
>>>> changed since version 3.6
>>>>
>>>> did you notice any compile errors when you added the subdivision files
>>>> to the povray source tree?
>>>
>>>
>>>
>>>
>
>
>
>


Post a reply to this message

From: Suman
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 12:15:01
Message: <web.53de27363102494a306240250@news.povray.org>
when i run povray without subdivision code like
mesh2 {
 vertex_vectors {
 .....
}
then i can see image online. and when i use the subdivision code like
mesh2 {
 subdivision{     // subdivision
        substeps 2    // subdivide 2 times
 }
 vertex_vectors {
 .....
}
then image not comes.



James Holsenback <nom### [at] nonecom> wrote:
> On 08/03/2014 07:46 AM, Suman wrote:
> > i did not notice any error during installation.
> > i am using exec command for image generation online.
> >
> > exec("/usr/local/bin/povray ...");
> > and no error is showing.
>
> yeah ok then ... i'll ask again not working how? does it even recognize
> any keywords associated with the subdivision patch ... do you even get a
> complete render?
>
> >
> >
> > James Holsenback <nom### [at] nonecom> wrote:
> >> On 08/03/2014 07:14 AM, Suman wrote:
> >>> Hi James,
> >>>
> >>> i downloaded POV-Ray Source Code here
> >>> http://www.povray.org/download/index-3.6.php
> >>> and update the source files of povray subdivision
> >>> from(http://www.cise.ufl.edu/~xwu/Pov-Sub/).
> >>>
> >>> i used the following command
> >>> ../configure COMPILED_BY="your name <email@address>" [options]
> >>>     make check
> >>>     make install
> >>
> >> Did you notice any errors or warnings from either the configure or make
> >> process?
> >>>
> >>> but after installation subdivision is not working.
> >>
> >> not working how ... does it even recognize any of the keywords
> >> associated with the subdivision patch?
> >>
> >>>
> >>> Thanks
> >>> Suman
> >>>
> >>>
> >>>
> >>> James Holsenback <nom### [at] nonecom> wrote:
> >>>> On 08/03/2014 06:43 AM, Suman wrote:
> >>>>> Hi,
> >>>>>
> >>>>> i installed povray with full source on server and moved the files of povray
> >>>>> subdivision(http://www.cise.ufl.edu/~xwu/Pov-Sub/) in source folder then i
> >>>>> installed povray on centos server. povray is working fine but povray
subdivision
> >>>>> is not working.
> >>>>>
> >>>>> when i using code below.
> >>>>>
> >>>>> mesh2 {
> >>>>>
> >>>>> subdivision{     // subdivision
> >>>>>         substeps 2    // subdivide 2 times
> >>>>>      }
> >>>>> vertex_vectors {
> >>>>> .....
> >>>>>
> >>>>> its showing error.
> >>>>>
> >>>>> Please help me to solve the installation issue.
> >>>>>
> >>>>> Thanks
> >>>>> Suman
> >>>>>
> >>>>>
> >>>>
> >>>> you didn't say where you got povray source code ... what version? the
> >>>> subdivision files were last updated in 2004 so if you used version 3.7
> >>>> povray source code there may be incompatibilities ... MANY things have
> >>>> changed since version 3.6
> >>>>
> >>>> did you notice any compile errors when you added the subdivision files
> >>>> to the povray source tree?
> >>>
> >>>
> >>>
> >>>
> >
> >
> >
> >


Post a reply to this message

From: James Holsenback
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 12:20:23
Message: <53de2907$1@news.povray.org>
On 08/03/2014 08:12 AM, Suman wrote:
> when i run povray without subdivision code like
> mesh2 {
>   vertex_vectors {
>   .....
> }
> then i can see image online. and when i use the subdivision code like
> mesh2 {
>   subdivision{     // subdivision
>          substeps 2    // subdivide 2 times
>   }
>   vertex_vectors {
>   .....
> }
> then image not comes.

you're not being specific enough ... does the program complete 
successfully when subdivision is used


Post a reply to this message

From: Suman
Subject: Re: Installation problem in povray subdivision on server.
Date: 3 Aug 2014 12:40:01
Message: <web.53de2d153102494a306240250@news.povray.org>
James Holsenback <nom### [at] nonecom> wrote:
> On 08/03/2014 08:12 AM, Suman wrote:
> > when i run povray without subdivision code like
> > mesh2 {
> >   vertex_vectors {
> >   .....
> > }
> > then i can see image online. and when i use the subdivision code like
> > mesh2 {
> >   subdivision{     // subdivision
> >          substeps 2    // subdivide 2 times
> >   }
> >   vertex_vectors {
> >   .....
> > }
> > then image not comes.
>
> you're not being specific enough ... does the program complete
> successfully when subdivision is used


its necessary because online renderer taking lots of time on server. and i did
not get complete package of povray with subdivision. may be some error in
subdivision files. therefore i am not able to generate image.


Post a reply to this message

Goto Latest 10 Messages Next 2 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.