POV-Ray : Newsgroups : povray.unix : Failure to configure properly in master branch Server Time: 20 Jun 2019 19:06:11 GMT
  Failure to configure properly in master branch (Message 1 to 4 of 4)  
From: Jonathan
Subject: Failure to configure properly in master branch
Date: 4 Jan 2014 01:00:01
Message: <web.52c75b5f72d39ade22b734b40@news.povray.org>
Hi,
My issue is that I'm using Cycas 3.9 [1] on Linux, which interfaces with a
locally-compiled Povray 3.7-stable by putting out an argument set like:

+I/home/jonathan/.cycas3/tmp//cycas.pov +P +D0 +X100 -V +SP32 +EP4 +W1024 +H768
+FC +O/home/jonathan/CYCAS3//tryit.png +Q9 +R1 +AM2 +A0.3 -J

This falls foul of a known bug [2] related to mosaic pretrace.  Rather than
intercept and process the argument set between Cycas and Povray, I thought it
might be easier to grab the current Master branch from github, and recompile
that, as it has Christoph's workaround for FS#313 in radiosity.cpp.

However, having executed prebuild.sh, I get an error with configure that I
didn't see with 3.7.0-stable.
[code]
$ ./configure COMPILED_BY="jonathan[at]blueyonder[dot]co[dot]uk"
--without-libmkl
......
checking whether to use the ZLIB library... yes
checking for library containing zlibVersion... no
configure: error: cannot find a suitable ZLIB library

$ dpkg -l | grep zlib
ii  zlib1g:amd64                             1:1.2.7.dfsg-13ubuntu2
   amd64        compression library - runtime
ii  zlib1g:i386                              1:1.2.7.dfsg-13ubuntu2
   i386         compression library - runtime
ii  zlib1g-dev:amd64                         1:1.2.7.dfsg-13ubuntu2
   amd64        compression library - development
[/code]
So I seem to have zlib development library installed.

And indeed, config.log seems to indicate that it's a problem with a boost
library (maybe - I'm getting out of my depth...)
[code]
configure:7946: g++ -o conftest  -pthread  -pthread -I/usr/include  -L/usr/lib
conftest.cpp -lz -lboost_thread-mt  -pthread  -lboost_system >&5
/usr/bin/ld: cannot find -lboost_system
collect2: error: ld returned 1 exit status
configure:7946: $? = 1
......
configure:7963: result: no
configure:8068: error: cannot find a suitable ZLIB library
[/code]
Comparing this with the relevant section of the successful config.log from
3.7.0-stable, I see there:
[code]
configure:7924: g++ -o conftest  -pthread  -pthread -I/usr/include  -L/usr/lib
conftest.cpp -lz -lrt -lm -lboost_thread-mt  -pthread  >&5
configure:7924: $? = 0
configure:7941: result: -lz
configure:7948: checking zlib.h usability
configure:7948: g++ -c  -pthread  -pthread -I/usr/include conftest.cpp >&5
configure:7948: $? = 0
configure:7948: result: yes
configure:7948: checking zlib.h presence
configure:7948: g++ -E  -pthread -I/usr/include conftest.cpp
configure:7948: $? = 0
configure:7948: result: yes
configure:7948: checking for zlib.h
configure:7948: result: yes
configure:7952: checking for libz version >= 1.2.1
configure:7974: g++ -o conftest  -pthread  -pthread -I/usr/include  -L/usr/lib
conftest.cpp -lz -lrt -lm -lboost_thread-mt  -pthread  >&5
configure:7974: $? = 0
configure:7974: ./conftest
1.2.7
configure:7974: $? = 0
configure:8013: result: 1.2.7, ok
[/code]
So, I conclude that the master branch configure is looking for lboost_system,
without success, whereas 3.7.0-stable didn't look for it when testing for zlib.
I have 14 libboost-* packages installed, including libboost1.49-dev.

Any help would be gratefully accepted, otherwise it's back to a bash hack on
that command line!

Jonathan

[1] http://www.cycas.de/features.php?s=en&sys=lin#top
[2] http://bugs.povray.org/task/313


Post a reply to this message

From: clipka
Subject: Re: Failure to configure properly in master branch
Date: 4 Jan 2014 14:17:44
Message: <52c81808$1@news.povray.org>
Am 04.01.2014 01:54, schrieb Jonathan:

> And indeed, config.log seems to indicate that it's a problem with a boost
> library (maybe - I'm getting out of my depth...)
> [code]
> configure:7946: g++ -o conftest  -pthread  -pthread -I/usr/include  -L/usr/lib
> conftest.cpp -lz -lboost_thread-mt  -pthread  -lboost_system >&5
> /usr/bin/ld: cannot find -lboost_system
> collect2: error: ld returned 1 exit status
> configure:7946: $? = 1
> .......

> So, I conclude that the master branch configure is looking for lboost_system,
> without success, whereas 3.7.0-stable didn't look for it when testing for zlib.
> I have 14 libboost-* packages installed, including libboost1.49-dev.
>
> Any help would be gratefully accepted, otherwise it's back to a bash hack on
> that command line!

Apparently we still haven't fully sorted out one of the breaking changes 
between boost 1.49 and 1.50, which is that since 1.50 the boost_thread 
library requires the boost_system library to be linked in.

In the 3.7.0-stable, this hadn't been addressed at all, making it 
necessary for people using boost 1.50 or higher to explicitly add 
boost_system to the list of libraries to be linked in.

In the current master branch, this has been changed, so that 
boost_system is now linked in automatically; however, apparently this 
now also happens with boost 1.49 and lower.

Sorry about this; I'll see what can be done to fix this problem. If 
you're in a hurry, try explicitly installing the boost_system library 
(you probably won't need the -dev package), or upgrade to boost 1.50 or 
higher.


Post a reply to this message

From: clipka
Subject: Re: Failure to configure properly in master branch
Date: 4 Jan 2014 14:38:18
Message: <52c81cda$1@news.povray.org>
Am 04.01.2014 15:17, schrieb clipka:

> Sorry about this; I'll see what can be done to fix this problem.

Okay, I think I've found the root cause. Can you please try with this 
branch:

https://github.com/POV-Ray/povray/tree/hotfix/boost1.49-boost_system

Please let me know if this solves your problem.


Post a reply to this message

From: Jonathan
Subject: Re: Failure to configure properly in master branch
Date: 4 Jan 2014 18:20:00
Message: <web.52c84ffca8bc544422b734b40@news.povray.org>
clipka <ano### [at] anonymousorg> wrote:
> Am 04.01.2014 15:17, schrieb clipka:
>
> > Sorry about this; I'll see what can be done to fix this problem.
>
> Okay, I think I've found the root cause. Can you please try with this
> branch:
>
> https://github.com/POV-Ray/povray/tree/hotfix/boost1.49-boost_system
>
> Please let me know if this solves your problem.

That works, thank you.  I've configured, had a successful 'make check' and then
installed using 'checkinstall -D make install'.  Everything works just as it
should; the proof is at
http://www.orlopdeck.net/piwigo/picture.php?/307/category/7

Thanks again for all your efforts keeping POVRAY going; I really appreciate it.

Jonathan


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.