POV-Ray : Newsgroups : povray.unix : UberPOV quit working after my OS upgrade Server Time: 14 Dec 2018 10:08:44 GMT
  UberPOV quit working after my OS upgrade (Message 1 to 2 of 2)  
From: Cousin Ricky
Subject: UberPOV quit working after my OS upgrade
Date: 5 Oct 2018 02:14:12
Message: <5bb6c8f4$1@news.povray.org>
I just upgraded my GNU/Linux system to openSUSE Leap 15.0 last weekend, 
and now running UberPOV yields the following error:

uberpov: error while loading shared libraries: libImath-2_1.so.11: 
cannot open shared object file: No such file or directory

My system has these files:

/usr/lib64/libImath-2_2.so.23.0.0
/usr/lib64/libImath.so
/usr/lib64/libImath-2_2.so.23
/usr/lib64/libImath-2_0.so.10.0.1
/usr/lib64/libImath-2_0.so.10

Should I just download the libImath-2_1.so.11 or is there some other 
resolution to this issue?

N.B.  The erstwhile POV-Ray 3.7.1 yields the same error.

OS: openSUSE Leap 15.0 (GNU/Linux)


Post a reply to this message

From: Le Forgeron
Subject: Re: UberPOV quit working after my OS upgrade
Date: 5 Oct 2018 06:09:20
Message: <5bb70010$1@news.povray.org>
Le 05/10/2018 à 04:14, Cousin Ricky a écrit :
> I just upgraded my GNU/Linux system to openSUSE Leap 15.0 last weekend, 
> and now running UberPOV yields the following error:
> 
> uberpov: error while loading shared libraries: libImath-2_1.so.11: 
> cannot open shared object file: No such file or directory
> 
> My system has these files:
> 
> /usr/lib64/libImath-2_2.so.23.0.0
> /usr/lib64/libImath.so
> /usr/lib64/libImath-2_2.so.23
> /usr/lib64/libImath-2_0.so.10.0.1
> /usr/lib64/libImath-2_0.so.10
> 
> Should I just download the libImath-2_1.so.11 or is there some other 
> resolution to this issue?
> 
> N.B.  The erstwhile POV-Ray 3.7.1 yields the same error.
> 
> OS: openSUSE Leap 15.0 (GNU/Linux)

You would have to recompile (actually for re-link) your programs with 
the current shared libraries to have it works again.

On the hacker side, you could make a symbolic link from 
libImath-2_1.so.11 to libImath.so ... and hope it stays compatible 
accross minor.

(but it does not work for libjpeg6 vs libjpeg8 nor for libpng )


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.